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本書について本書について本書について本書について 

はじめにはじめにはじめにはじめに
この章では本書とカスタマーサポートの御利用方法について書いてありま
す。

ポイントポイントポイントポイント
この章で扱う項目は以下のとうりです。

• 本書の内容

• 参考情報

• 保証登録について

• 問題解決方法

• マイクロチップインターネットウエブサイト

• 開発システムユーザーへのヘルプサービス

• カスタマーサポート

本書の内容本書の内容本書の内容本書の内容

本書の項目について本書の項目について本書の項目について本書の項目について

PICSTART Plus は、PICmicro デバイスでファームウエアをプログラムするた
めの開発ツールでのことで、本書にはその使い方について書いてあります。
　本書の項目は、次のようになっています。

• Chapter 1: PICSTART Plus プレビュープレビュープレビュープレビュー – PICSTART Plus とその動作
について書いてあります。

• Chapter 2: PICSTART Plus のインストールとセットアップのインストールとセットアップのインストールとセットアップのインストールとセットアップ – PIC-
START Plus ハードウエアと MPLAB IDE ソフトウエアのインストール
方法、MPLAB IDE と PICSTART Plus を一緒に使用するためのセット
アップ方法、 MPLAB IDE から PICSTART Plus をスタートさせる方法
について説明します。

• Chapter 3: プログラミング作成例プログラミング作成例プログラミング作成例プログラミング作成例 – calibration メモリーデバイス、メ
モリーデバイス、その他の PICmicro® MCU デバイスをプログラムす
るためのプログラミング作成例（チュートリアル）が載っています。

• Chapter 4: MPLAB と一緒にと一緒にと一緒にと一緒にPICSTART Plusを使用するを使用するを使用するを使用する – デバイスを
プログラム、リード、ベリファイするための PICSTART Plus の使い
方を順を追って説明します。

• Chapter 5: PICSTART Plus – MPLAB Reference – PICSTART Plus ダ
イアログとメニューオプションについて書いてあります。
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• Appendix A: 25-Pin シリアルポートへの接続シリアルポートへの接続シリアルポートへの接続シリアルポートへの接続 – 25-pin シリアルポート
への PICSTART Plus の接続方法について書いてあります。

• Appendix B: PICSTART Plus VPP 調整調整調整調整 –改訂されたプログラミング仕
様で動作させるために、 古くなった PICSTART Plus ハードウエアユ
ニットの VPP プログラミング電圧を変更する方法 

• Appendix C: 問題解決方法問題解決方法問題解決方法問題解決方法 – 一般的な問題の解決方法を示してありま
す。

• 索引索引索引索引 – 用語、イラスト図、本書のセクションの全リストが載っていま
す。

• 海外販売サービス海外販売サービス海外販売サービス海外販売サービス – 海外のマイクロチップ社販売サービスの住所と電
話番号が載っています。

本書に使用されている記号の意味本書に使用されている記号の意味本書に使用されている記号の意味本書に使用されている記号の意味

本書では、使用されている下記の記号にそれぞれ決まった意味があります。 
本書の表記本書の表記本書の表記本書の表記

記号記号記号記号 意味意味意味意味 例例例例

文字の種類文字の種類文字の種類文字の種類 (Courier font):
全角英数文字 サンプルコード

ファイル名と paths
#define START
c:\autoexec.bat

山がた カッコ : < > Variables <label>, <exp>
角カッコ [ ] Optional arguments MPASMWIN 

[main.asm]
中カッコと pipe 
character: { | }

相反する arguments の選択
OR 選択

errorlevel {0|1}

引用符内の小文字 データの種類 “filename”
Ellipses... 例には関係しない追加テキス

トを意味する（表示はなし）
list 
[“list_option...
, “list_option”]

0xnnn n が 60進法の数字で 60進法の
数を表す

0xFFFF, 0x007A

イタリック体文字 意味が変わるもの ; データの種
類 ( 小文字では ) または特殊な
例 (uppercase 文字では ) を表
す

char isascii 
(char, ch);

Interface (Helvetica font):
下線付きの右矢印
イタリック文字

メニューバーからのメニュー
の選択を表す

File > Save

Bold 文字 クリック用のウインドウまた
はダイアログの文字

OK, Cancel

山がたカッコ
 < > 内の文字

キーボード上のキーを表す <Tab>, <Ctrl-C>

ドキュメントドキュメントドキュメントドキュメント (Helvetica フォントフォントフォントフォント ):
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アップデートアップデートアップデートアップデート

ドキュメントは、本書も含め、いずれ内容が古くなります。MPLAB IDE、 
PICSTART Plus や他のマイクロチップ製品はユーザーのニーズにお応えす
るよう絶えず改良されているため、MPLAB ダイアログやツール表示のいく
つかが本書と異なる場合があります。 そのような場合は、下記のウエブサイ
トにアクセスし最新のデータシートを入手されることをお勧めします。 

 http://www.microchip.com 

保証登録について保証登録について保証登録について保証登録について

保証登録カードに必要事項を御記入の上、すぐに郵送して下さい。これによ
り新製品のアップデートを受け取ることができます。マイクロチップウエブ
サイトで補助的ソフトウエアが入手できます。  

参考情報参考情報参考情報参考情報
本書には PICSTART Plus の使い方が書かれています。データシートには、
いくつかのマイクロコントローラーデバイスをプログラムするための最新情
報が載っています。 
README.PLS
 PICSTART Plusを使用する時の最新情報は、 PICSTART Plusソフトウエアに
入っている README.PLS file (ASCII テキストファイル ) をリードして下さ
い。 README.PLS ファイルには、本書に書かれていない最新情報が 載って
います。

MPLAB IDE User’s Guide (DS51025)
マイクロチップ社の MPLAB Integrated Development Environment (IDE) の
インストール方法と特徴、また MPLAB 環境のエディタとシミュレータ機能
が、わかりやすく書かれたガイドブックです。 
MPASM User’s Guide with MPLINK & MPLIB (DS33014)
Microchip Universal PICmicro Microcontroller Assembler (MPASM)と、 Linker 
(MPLINK) そして Librarian (MPLIB) の使用方法が書かれています。

イタリック文字 参考文献 MPLAB IDE User’s 
Guide

本書の表記本書の表記本書の表記本書の表記 (Continued)

記号記号記号記号 意味意味意味意味 例例例例



PICSTART® Plus User’s Guide

DS51028C_J-page 4  2000 Microchip Technology Inc.
　　　　　　　　　　　この日本語ドキュメントは参考資料です。　最新版英語ドキュメントをご参照下さい。
　　　　　　　　　　　　　　　　　　　　(http：//www.microchip.com から入手できます）

Technical Library CD-ROM (DS00161)
この CD-ROM は入手可能な Microchip PICmicro® MCU デバイスのデータ
シートが記載されています。この CD-ROM を御希望の際は、お近くのマイ
クロチップ社や販売代理店（巻末を御覧ください）にお問い合わせ下さい。 
または、マイクロチップウエブサイト (http://www.microchip.com) から個々
のデータシートをダウンロードして下さい。

Embedded Control Handbook (DS00711)
このハンドブックは、マイクロコントローラアプリケーションに関する豊富
な情報を含むいくつかのドキュメントにより構成されています。 このハンド
ブックを御希望の際は、お近くのマイクロチップ社や販売代理店（巻末をご
覧下さい）にお問い合わせ下さい。

これらのマニュアルに書かれているアプリケーションノートも、 マイクロ
チップ社や販売代理店、またはマイクロチップウエブサイト (http://
www.microchip.com) から入手できます。

PICmicro Mid-Range MCU Family Reference Manual (DS33023)
このマニュアルは、MCU 関連製品のアーキテクチャと周辺モジュール の汎
用とオペレーションについて説明しています。 デバイスのデータシートを補
足する目的で作成されています。 
Microsoft® Windows® Manuals
ユーザーが、マイクロソフトウインドウズのオペレーティングシステムを理
解できるように書かれています。このソフトウエアプログラムについては、
たくさんの優れた参考例が載っており、ウインドウズの幅広いオペレーショ
ンを調べるのに役立ちます。  

問題解決方法問題解決方法問題解決方法問題解決方法
一般的なトラブルについては、Appendix C をご覧下さい。  
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マイクロチップインターネットウエブサイトマイクロチップインターネットウエブサイトマイクロチップインターネットウエブサイトマイクロチップインターネットウエブサイト
マイクロチップ社ではマイクロチップワールドワイドウエブ (WWW) サイト
でオンラインサポートを行っています。

このウエブは、ユーザーがファイルや情報を簡単に入手するためのものです。
サイトを見るためには、Netscape® Communicator または Microsoft® Internet
Explorer® などのようなインターネットやウエブブラウザにアクセスして下
さい。FTP サイトから FTP ダウンロード用にファイルを入手することもでき
ます。

マイクロチップインターネットウエブサイトへの接続マイクロチップインターネットウエブサイトへの接続マイクロチップインターネットウエブサイトへの接続マイクロチップインターネットウエブサイトへの接続

マイクロチップウエブサイトを利用するには、  
http://www.microchip.com

に接続して下さい。

ファイル転送サイトは、 FTPプログラム /クライアントを使用して下記に接続
すれば可能です。 

ftp://ftp.microchip.com
このウエブサイトとファイル転送サイトにより、幅広いサービスが御利用い
ただけます。最新のツール、データシート、アプリケーションノート、ユー
ザーズガイド、Articles そしてサンプルプログラムがダウンロードできます。
マイクロチップの特別なビジネス情報、マイクロチップ社や販売代理店、工
場のリストも入手できます。他に参考になるデータには、下記のものがあり
ます。

• マイクロチップの出版情報

• 頻度の高い質問にお答えするテクニカルサポートセクション 
• デザイン Tips
• デバイスエラッタ

• Job Postings
• マイクロチップコンサルタントプログラムメンバーリスト

• マイクロチップ製品に関連する他の役に立つウエブサイト 
• 弊社の製品、開発システム、技術的な情報やその他に関する相談 
• セミナー、イベント情報
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開発システムユーザーへのヘルプサービス開発システムユーザーへのヘルプサービス開発システムユーザーへのヘルプサービス開発システムユーザーへのヘルプサービス
マイクロチップ社では、ユーザーに製品をよりスムーズに御使用いただくた
めに、カスタマーへの注意事項サービスを始めました。リストに載っている
サーバーにお申し込みいただくと、御使用の製品シリーズと開発ツールに関
連したエラッタが、変更、アップデート、修正されるたびに、弊社から E
メールで情報をお届けします。マイクロチップのリストサーバーについて
は、 http://www.microchip.com を御覧下さい。

開発システムリストの項目は、下記のとうりです。

• コンパイラ

• エミュレータ

• プログラマー

• MPLAB
• O ツール ( 他のツール )

この中で調べたい項目がある場合は、

listserv@mail.microchip.com 
にアクセスしてから、下の一行を加えて下さい。

subscribe <listname> yourname
例：  

subscribe programmers John Doe 
お申し込みを中止する場合は、

listserv@mail.microchip.com 
にアクセスしてから、下の一行を加えて下さい。

unsubscribe <listname> yourname
例： 

unsubscribe programmers John Doe
次のセクションでは、開発システムのリストについて紹介します。

コンパイラコンパイラコンパイラコンパイラ

マイクロチップ C コンパイラ、リンカーとアセンブラーの最新情報です。

ライブラリアンすなわち MPLINK 用の MPLIB と同様に、MPLAB-C17、 
MPLAB-C18、 MPLINK、 MPASM が含まれます。

このリストへの接続は、

listserv@mail.microchip.com 
にアクセスしてから、下の１行を加えて下さい。

subscribe compilers yourname
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エミュレータエミュレータエミュレータエミュレータ

マイクロチップインサーキットエミュレータの最新情報です。MPLAB-ICE 
と PICMASTER が含まれます。

このリストへの接続は、

listserv@mail.microchip.com 
にアクセスしてから、下の１行を加えて下さい。

subscribe emulators yourname

プログラマープログラマープログラマープログラマー

マイクロチップ PICmicro デバイスプログラマーの最新情報です。PRO 
MATE II と PICSTART Plus が含まれます。

このリストへの接続は、

listserv@mail.microchip.com 
にアクセスしてから、下の１行を加えて下さい。

subscribe programmers yourname

MPLAB
マイクロチップ MPLAB すなわち開発システムツール用のウインドウズイン
テグレーテッド開発環境の最新情報です。 このリストには、特に MPLAB、 
MPLAB-SIM、 MPLAB のプロジェクトマネジャーや general エディットと 
features のデバッグについて記載されています。 MPLAB コンパイラ、リン
カーとアセンブラーの詳しい情報については、COMPILERS リストに、 
MPLAB エミュレータの詳しい情報については、EMULATORS リストにそれ
ぞれ接続して下さい。また、MPLAB デバイスプログラマーの詳しい情報に
ついては、PROGRAMMERS リストに接続して下さい。

このリストへの接続は、

listserv@mail.microchip.com 
にアクセスしてから、下の１行を加えて下さい。

subscribe mplab yourname

O ツールツールツールツール

マイクロチップ社の他の開発システムツールの最新がわかります。 MPLAB 
とそのインテグレーテッドツールに関する詳しい情報については、下記の
メールリストに接続して下さい。

listserv@mail.microchip.com 
にアクセスしてから、下の１行を加えて下さい。

subscribe otools yourname
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カスタマーサポートカスタマーサポートカスタマーサポートカスタマーサポート
マイクロチップ社製品のユーザーはいくつかの方法でサポートが受けられま
す。

• 代理店またはマイクロチップテクノロジー社

• 各地の販売店

• フィールドアプリケーションエンジニア (FAE)
• コーポレートアプリケーションエンジニア (CAE)

• ホットライン

ユーザーは代理店やマイクロチップテクノロジー社、フィールドアプリケー
ションエンジニア (FAE) にサポートを求めることができます。各地の販売店
でもユーザーのサポートが可能です。巻末にある連絡先を御参照下さい。

コーポレートアプリケーションエンジニア (CAEs) の連絡先は、
(480) 786-7627　です。

さらにシステムインフォメーションとアップグレード用の連絡先もありま
す。ここでは、マイクロチップ開発環境ソフトウエア製品すべての最新情報 
リストを提供できます。またアップグレード製品の入手方法もユーザーにお
知らせしています。

このホットラインの電話番号は、アメリカとカナダでは、　 
1-800-755-2345 
その他の国々では、 
1-480-786-7302 　です。
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PICSTART® PLUS USER’S GUIDE12
Chapter 1.  クイックスタートクイックスタートクイックスタートクイックスタート

1.1  はじめにはじめにはじめにはじめに
この章では PICSTART Plus を短時間で使用できるように、PC や embedded 
アプリケーション開発ツールのユーザーが必要とする情報について短く述べ
てあります。

1.2  ポイントポイントポイントポイント
この章で扱う項目は次のとうりです。

• MPLAB® IDE と PICSTART Plus のインストール

• PICSTART Plus と PC との接続

• MPLAB IDE を使った PICSTART Plus の使用

- PICSTART Plus のイネーブル ( 開始 ) 
- Device Programmer と Configuration Bits のセットアップ

- Hex ファイルのロード

- Blank Device のチェック

- デバイスのプログラム、ベリファイ、リード

1.3  MPLAB IDE とととと PICSTART Plus のインストールのインストールのインストールのインストール
1. PICSTART Plus は MPLAB Integrated Development Environment (IDE)

のコンポーネントです。MPLAB IDE ソフトウエアをインストールする
には、MPLAB IDE のインストール用 CD を入れ、 MPXXXX.EXEを作動
させます。XXXXは MPLAB IDE ソフトウエアのバージョンを示してい
ます。この作り方は CD の root directory に入っています。

2. インストールプログラムのコンポーネント選択ウインドウが出たら、イ
ンストールするコンポーネントのリストで、PICSTART Plus にチェッ
ク印が付いているかどうかを確認して下さい。最小限の手順として、
MPLAB IDE ソフトウエアと MPASM/MPLINK をインストールします。
MPLAB-SIM とヘルプファイルもインストールする必要があります。イ
ンストールプログラムにより表示された指示に従ってインストールを
続けて下さい。Language Components では、All を選択します。

以前に MPLAB IDE ソフトウエアのみインストールして PICSTART Plus を
インストールしていない場合は、もう一度インストールを行って下さい。 
PICSTART Plus 以外の全てのチェックマークをクリアにすることができま
す。
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1.4  PICSTART Plus とととと PC との接続との接続との接続との接続
PICSTART Plus と PC を接続するために次の手順に従って下さい。.

1. PCの使用可能なCOM ポートにPICSTART Plus を接続するために、RS-
232 コミュニケーションケーブルをしようして下さい。

2. 電源をインストールします。

MPLAB IDE を使った PICSTART Plus の使用がこれで可能になります。

1.5  MPLAB IDE を使ったを使ったを使ったを使った PICSTART Plus の使用の使用の使用の使用

1.5.1 PICSTART Plus の開始の開始の開始の開始

1. MPLAB デスクトップアイコンをダブルクリックするか、または Start
menuから Programs > Microchip MPLAB > MPLABを選択することによ
り MPLAB IDE をスタートさせます。 

2. MPLAB メニューより Options > Programmer Options > Communica-
tions Port Setup を選択します。PICSTART Plus がオンになっている
COM ポートを選択して下さい。

3. PICSTART Plus メニューアイテムが MPLAB メニューにない時は、
PICSTART Plus プログラマーを選択しなければなりません。 MPLAB
デスクトップでは、Options > Programmer Options > Select Program-
mer を選択します。PICSTART Plus Device Programmer を選択し、OK
をクリックして下さい。 変更を行うためにMPLAB ソフトウエアを再ス
タート するよう促すメッセージが現れるので、Yes をクリックして下
さい。 MPLAB IDE は閉じます。MPLAB IDE ソフトウエアを再スタート
する時に PICSTART Plus メニューは MPLAB メニュー上に現れます。

4. Options > Development Mode を選択します。MPLAB-SIM または Editor
Only 開発モードを選択し、これからプログラムするデバイスを選択し
て下さい。OK をクリックします。

5. MPLAB メニューよりPICSTART Plus > Enable Programmerを選択して
下さい。MPLAB IDE は PICSTART Plus とのコミュニケーションを確
立しようと試みます。そして、PICSTART Plus Device Programmer と
Configuration Bits ダイアログと同様に Program Memory ウインドウが
現れます。

注意注意注意注意

ソケット内のデバイスと電源をつながないで下さい。デ
バイスがダメージを受けることがあります。
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クイックスタートクイックスタートクイックスタートクイックスタート

1.5.2 Device Programmer とととと Configuration Bits のセットのセットのセットのセット
アップアップアップアップ

PICSTART Plus Device Programmer ダイアログはプログラマーがイネーブ
ルになるといつでも開きます。 このダイアログを閉じるとプログラマーが
ディセーブルとなります。

1. 正しいデバイスが表示されていることを確認して下さい。もしプログラ
ムしたいデバイスがリストに載っていない時は、 PICSTART Plus オペ
レーティングシステムセクション (6.9をご覧ください )をアップグレー
ドする必要があります。MPLAB IDE ソフトウエアの最新バージョンの
みアップグレードする必要もあります。

2. デバイス(例えば、バージョンコントロール等)上のプログラムを確認し
たい時は、Device ID をクリックしてデバイス ID をエディットするか
プロテクトされていないチェックサムを選択して下さい。OK をクリッ
クします。

3. Configuration Bits ダイアログ内のコンフィギュレーションビットを
セットします。ソースコードにコンフィギュレーションビットをセット
すると、このダイアログはプロジェクトを再ビルドする時の値にアップ
デートされます。このダイアログ内の値はこれからプログラムするデバ
イスにプログラムされます。

Configuration Bits ダイアログが見えない時は、PICSTART Plus Device
Programmer ダイアログ内の Configuration Bits をクリックして再び開
いて下さい。

1.5.3 Hex File のロードのロードのロードのロード

デバイスにプログラミングできる状態の hex ファイルがある場合は、File > 
Import > Import to Memoryを選択してMPLAB Program Memoryウインドウに
hex コードをロードして下さい。 Window > Program Memory を選択し、プロ
グラムメモリーの内容を見ます。

1.5.4 Blank Device のチェックのチェックのチェックのチェック

プログラムしたいデバイスを PICSTART Plus ソケットに差し込みます。
PICSTART Plus Device Programmer ダイアログにある Blank をクリックし、
デバイスがブランクである ( 全てのビットが ‘1’ にセットされている ) ことを
確認して下さい。

もし one-time programmable (OTP) デバイスをプログラムしている場合は、 
Configuration Bits ダイアログを使用してコンフィギュレーションビットをそ
れらの生産時のセッティングにセットします。 PICSTART Plus > Blank 
Check OTP を選択して、全てのプログラムメモリービットが ‘1’ にセットさ
れていること、またそれらのコンフィギュレーションビットが Configuration 
Bits ダイアログ内の値と一致していることを確認して下さい。
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1.5.5 デバイスのプログラム、ベリファイ、リードデバイスのプログラム、ベリファイ、リードデバイスのプログラム、ベリファイ、リードデバイスのプログラム、ベリファイ、リード

ここまでのセクションの手続きが完了していれば、デバイスのプログラムが
可能になります。 デバイス全体をプログラムするには、 PICSTART Plus 
Device Programmer ダイアログ内の Program をクリックします。.

選択的に ( プログラムメモリーの一部またはコンフィギュレーションビット
等 ) プログラムを行うには、PICSTART Plus > Program/Verify を選択しま
す。 プログラムするメモリー領域と項目を選択し、Program/Verify ダイアロ
グ内の Program をクリックします。

プログラムが完了したら、 “Success” または “Failure” の文字が Start Address
の右に出ます。プログラミングが失敗すると期待値と実際値を表示したエ
ラーウインドウが現れます。 

Note: 窓付き測定デバイスをプログラムする時は、デバイスの正しいオ
ペレーションを守るために、セクション 4.3.3.4 に述べられている
ように測定データを必ず保存して下さい。 
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PICSTART® PLUS USER’S GUIDE12
Chapter 2.  PICSTART Plus プレビュープレビュープレビュープレビュー 

2.1  はじめにはじめにはじめにはじめに 
この章では、PICSTART Plus 開発プログラマーの概要を述べます。 
PICSTART Plus の特徴や使用時に必要なものが載っています。

2.2  ポイントポイントポイントポイント
この章に出てくる項目は次のとうりです。

• PICSTART Plus とは何か

• PICSTART Plus システムのコンポーネンツ 

• PICSTART Plus CE コンプライアンス

• PICSTART Plus の利用法

• MPLAB インテグレーテッド開発環境

• MPLAB 開発ツール

2.3  PICSTART Plus とは何かとは何かとは何かとは何か
PICSTART Plus は、ユーザーのソフトウエアを PICmicro マイクロコント
ローラー (MCU) デバイス (DIP パッケージのみ —PIC16C9XX と
PIC17C7XX デバイス用に使用できるアダプター ) にプログラムできるマイ
クロチップマイクロコントローラー開発プログラマーのことです。.

Note: PICSTART Plus 開発システムは、ファームウエア開発用に設計さ
れており、製品生産などの使用目的用には設計されていません。  
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2.4  PICSTART Plus システムのコンポーネンツシステムのコンポーネンツシステムのコンポーネンツシステムのコンポーネンツ
PICSTART Plus デバイスプログラマーシステムは、下記のものから構成さ
れています。

1. PICSTART Plus デバイスプログラマー

2. 標準の PC シリアルポートならどれでも接続できる RS-232 インター
フェイスケーブル

3. MPLAB IDE ソフトウエア、すなわち text エディタ、プロジェクトマネ
ジャー、MPASM アセンブラー、MPLAB-SIM シミュレータを含むイン
テグレーテッド開発環境 

4. プログラミング用ブランクチップ

5. 9V の供給電力 ( 写真には載っていません )

Figure 2.1:  PICSTART Plus システムシステムシステムシステム

2.5  PICSTART Plus CE コンプライアンスコンプライアンスコンプライアンスコンプライアンス
PICSTART Plus 開発システムの設計、テスト、保証は、CE コンプライアン
スディレクティブ として知られるエレクトロマグネティック Compatibility 
に必要なものに合わせて行われています。 欧州連合 (EU) 国により定められ
たこれらの標準は、 放射状の emission の限定、 放射状の emission の磁化率
の減少、そして Electrostatic Discharge (ESD) の磁化率の減少の機能を含み
ます。

1

2

3

4
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PICSTART Plus プレビュープレビュープレビュープレビュー

2.6  PICSTART の利用法の利用法の利用法の利用法
PICSTART Plus デバイスプログラマーシステムには次のような特徴があり
ます。

• プログラムメモリー、コンフィギュレーションビット、そして ID ロ
ケーションを含む PICmicro MCU をプログラムします。 

•  標準 RS-232 ケーブルを介して、PC と接続できます。

• MPLAB インテグレーテッド開発環境内で、PC- コンパチブルホストシ
ステム上のMicrosoft® Windows® アプリケーションとして動作します。 

• MPLAB IDE 内では、PICmicro MCU 内にプログラムされるファイルの
作成、表示、編集ができます。 you can create, dis 

さらに、PICmicro MCU がブランクであること、またターゲットマイクロコ
ントローラーがユーザーのファームウエアに適合することを確かめることが
できます。また他の PICmicro デバイスにデバッグまたはプログラムするた
めにプロテクトされていない PICmicro MCU から MPLAB IDE のプログラム
メモリーウインドにコードを rdad することができます。

2.7  MPLAB インテグレーテッド開発環境インテグレーテッド開発環境インテグレーテッド開発環境インテグレーテッド開発環境 
MPLAB IDE デスクトップは、アプリケーションの開発やデバッグ用に イン
テグレーテッド開発環境 (IDE) を提供しています。PICSTART Plus は 
MPLAB IDE 内にインテグレートされます。

本書には、PICSTART Plus デバイスプログラマーの基本的なセットアップ
とオペレーションが載っていますが、MPLAB IDE の全機能は扱っていませ
ん。 MPLAB IDE の特徴とデバッグ容量についてさらに詳しく知りたい方は、
MPLAB IDE User’s Guide (DS51025) をお読み下さい。



PICSTART® Plus User’s Guide

DS51028C_J-page 16                                                        2000 Microchip Technology Inc.  
　　　　　　　　　　　この日本語ドキュメントは参考資料です。　最新版英語ドキュメントをご参照下さい。　　　　　　　　

　　　　　　　　　　　　　　　　　　　(http://www.microchip.com から入手できます）

2.8  MPLAB 開発ツール開発ツール開発ツール開発ツール
MPLAB IDE は完全な開発環境を提供するためにいくつかのツールをインテ
グレートしています。

• MPLAB プロジェクトマネジャープロジェクトマネジャープロジェクトマネジャープロジェクトマネジャー

プロジェクトの作成用には Project Manager を使い、 そのプロジェクト
に関連したファイルと一緒に操作します。プロジェクトを使用する時
は、 マウスを１度クリックするだけで、ソースコードを rebuild してシ
ミュレータまたはエミュレータにダウンロードできます。

• MPLAB エディタエディタエディタエディタ

ソースファイルやコード、linker script ファイルなどのようなテキスト
ファイルの作成や編集用に MPLAB エディタを使います。 

• MPLAB-SIM シミュレータシミュレータシミュレータシミュレータ

ソフトウエアシミュレータは PICmicro MCU の命令実行と I/O を行い
ます。

• MPLAB-ICE エミュレータエミュレータエミュレータエミュレータ

MPLAB-ICE エミュレータは、ターゲットシステムのある無しにかかわ
らず、リアルタイムで PICmicro MCU を emulate するためにハードウ
エアを使います。 

• MPASM アセンブラーアセンブラーアセンブラーアセンブラー /MPLINK リンカーリンカーリンカーリンカー /MPLIB ライブラリアンライブラリアンライブラリアンライブラリアン

MPASM アセンブラーは、MPLAB を残すことなくソースコードをアセ
ンブルします。MPLINK は MPASM、 MPLAB-C17、 MPLAB-C18 から
relocatableモジュールをリンクすることにより、最終アプリケーション
を作成します。MPLIB は最大コードを再使用できるようにカスタムラ
イブラリーを管理します。

• MPLAB-CXX C コンパイラーコンパイラーコンパイラーコンパイラー

MPLAB-C17とMPLAB-C18 C コンパイラーは、ANSIベースハイレベル
ソースコードソリューションを提供します。 Complex プロジェクトは
C のコンビネーションを使用でき、アセンブリーソースはスピードと維
持性を最大限に利用できるようにファイルします。 

• PRO MATE® II and PICSTART Plus プログラマープログラマープログラマープログラマー

シミュレータまたはエミュレータでコードを開発し、それをアセンブ
ルまたはコンパイルします。そしてこれらのツールのうち一つを使用し
てデバイスをプログラムします。 これはすべて MPLAB IDE で実行でき
ます。 PRO MATE II が MPLAB IDE に動作を命令しない時は、プログラ
ム作成には MPLAB IDE を使用する方が簡単です。

• サードパーティーツールサードパーティーツールサードパーティーツールサードパーティーツール

多くの他のメーカーが、MPLAB  IDE を使うマイクロチップ製品用の開
発ツールを出しています。 Microchip Third Party Guide (DS00104) を御
参照下さい。
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PICSTART® PLUS USER’S GUIDE12
Chapter 3.  PICSTART Plus のインストールのインストールのインストールのインストール

3.1  はじめにはじめにはじめにはじめに
PICSTART Plus 開発システムは、 MPLAB IDE ソフトウエアのインストール
と同様に、PC にハードウエアを接続する必要があります。 この章ではハー
ドウエアとソフトウエア両方のインストールについて述べています。 

3.2  ポイントポイントポイントポイント
この章で扱う項目は、下記のとうりです。

• ホストコンピュータシステム命令

• IPICSTART Plus ハードウエアのインストール

• IMPLAB IDE ソフトウエアのインストール

• MPLAB IDE の起動

• PICSTART Plus 用シリアルポートのコンフィギャ

• MPLAB IDE 開発モードのセットアップ

• PICSTART Plus の起動

3.3  ホストコンピュータシステム命令ホストコンピュータシステム命令ホストコンピュータシステム命令ホストコンピュータシステム命令
MPLAB IDE を動作させるのに下記の最小コンフィギュレーションが必要で
す。

• Pentium® クラスの PC
• マイクロソフトウインドウズ 3.x、ウインドウズ 95/98、ウインドウズ

NT® またはウインドウズ 2000®

• 16 MB メモリー (32 MB がベスト )
• 45 MB のハードディスク容量

･ シリアルポート１個

3.4  PICSTART Plus ハードウエアのインストールハードウエアのインストールハードウエアのインストールハードウエアのインストール
PICSTART Plus ハードウエアはセットアップが簡単です。コミュニケー
ションケーブルを取り付ければ、電源に接続できます。

3.4.1 ケーブルのインストールケーブルのインストールケーブルのインストールケーブルのインストール

PICSTART Plus は、RS-232 9 ピンすなわち D タイプコネクターによりホス
ト PC にデータを伝えます。 PICSTART Plus はデータコミュニケーション装
置 (DCE) で、ハードウエアハンドシェーキングは、Clear-To-Send (CTS) と 
Request-To-Send (RTS) を介して行われます。 
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DB-9 コネクター付き A 6 フィートデータケーブルは、PICSTART Plus に供給
されます。データケーブル上の全てのラインは直接つながっています。 この
ケーブルは null モデムケーブルではありません。

• PC 上の COM ポートにケーブルの一方の端を接続します。PC のセット
アップをチェックして、どのコミュニケーションポートが利用できる
かを見ます。 普通はマウスデバイスが COM1 または COM2U に接続し
ています。モデムを御使用の場合は、PC にサードシリアルポートが
ついていないかも知れません。

• COM ポートから PICSTART Plus 開発プログラマーにケーブルを接続
します。

3.4.2 電源のインストール電源のインストール電源のインストール電源のインストール

PICSTART Plus は 9V 入力の電力を使用します。

PICSTART Plus は中心の正2.5 mmターミナルに500 mA (最大で) で +9 ボル
ト ±10% の電力を必要とします。 

• パワーソケットにコードをつなげ、PICSTART Plus に電力ケーブルを
接続します。 

注意注意注意注意

デバイスがソケットに入っている状態で電源を入れない
で下さい。デバイスにダメージを与えます。  
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PICSTART Plus のインストールのインストールのインストールのインストール

3.5  MPLAB IDE ソフトウエアのインストールソフトウエアのインストールソフトウエアのインストールソフトウエアのインストール
MPLAB IDE User’s Guide (DS51025)の指示に従いMPLAB IDEソフトウエア
をインストールします。PICSTART Plus アップグレードを行ったりインス
トールしたりする方法と一緒に、この手順を要約したものが下記に述べられ
ています。  

3.5.1 インストールの手順インストールの手順インストールの手順インストールの手順

MPLAB IDE User’s Guide には更に詳しい説明が載っています。

• MPLAB IDE CD-ROMをお持ちのCD-ROM ドライブに入れます(例えば
ドライブ D 等 )。

• セットアッププログラムを起動します。

- Windows 3.x/NT 3.51: プログラムマネジャーから Run オプショ
ンのタイプ D:\setup.exe を起動させます。

- Windows 95/98, Windows NT 4.0, またはまたはまたはまたは Windows 2000:  ス
タートメニューから Run を選択します。Run ダイアログでは、 
タイプ D:\setup.exe (D が御使用のコンピューターの CD-ROM 
ドライブの場合 ) を起動させます。

• MPLAB IDE をインストールするために on-screen の指示に従って下さ
い。 PICSTART Plus をインストールするチェックボックスを必ず確認
して下さい (Figure 3.1)

Figure 3.1:  Select Components ダイアログダイアログダイアログダイアログ
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3.6  MPLAB IDE の起動の起動の起動の起動 
MPLAB IDE が PC にインストールされたら、下記の方法のどれかで起動して
下さい。

• Windows 3.x/NT 3.51: MPLAB アイコンをダブルクリックして下さ
い。

• Windows 95/98, Windows NT 4.0, またはまたはまたはまたは Windows 2000: Start メ
ニューから Programs > Microchip MPLAB > MPLAB を選択します。 
MPLAB デスクトップは Figure 3.2 のように見えるはずです。

Figure 3.2:  MPLAB デスクトップデスクトップデスクトップデスクトップ
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PICSTART Plus のインストールのインストールのインストールのインストール

3.7  PICSTART Plus 用シリアルポートのコンフィギュ用シリアルポートのコンフィギュ用シリアルポートのコンフィギュ用シリアルポートのコンフィギュ
アアアア

MPLAB IDE から Options > Programmer Options > Communications Port 
Setup を選択します。Figure 3.3 のようなダイアログが現れます。

Figure 3.3:  コミュニケーションポートセットアップダイアログコミュニケーションポートセットアップダイアログコミュニケーションポートセットアップダイアログコミュニケーションポートセットアップダイアログ

コミュニケーションポートセットアップダイアログは、使用可能な PC シリ
アルコミュニケーションポートを示します。PICSTART Plus を接続した 
COM ポートを選択し、OK をクリックします。MPLAB IDE がポートを確か
めるために PICSTART Plus にコンタクトしようとします。 COM ポートを選
択せずにダイアログを閉じたい時は、Cancel をクリックします。

PICSTART Plus が選択した COM ポート上で見つからない場合は、
Figure 3.4 のようなダイアログが現れます。 

Figure 3.4:  コミュニケーションエラーダイアログコミュニケーションエラーダイアログコミュニケーションエラーダイアログコミュニケーションエラーダイアログ

No をクリックすると、PICSTART Plus に再コンタクトせずに新しい COM を
保存します。Yes をクリックすると、MPLAB IDE は記入された COM ポー
トで PICSTART Plus にコンタクトしようとします。

PC と PICSTART Plus の間でコミュニケーションがとれない時は、ハードウ
エアとソフトウエアを正しくインストールしたかどうか確かめて下さい ( 3
章を御覧ください )。それでもコミュニケーションが確立しない時は、 
Appendix C を御覧ください。 
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3.8  MPLAB 開発モードのセットアップ開発モードのセットアップ開発モードのセットアップ開発モードのセットアップ
Options > Development Mode を選択し、セットされた開発モード変更用と
プロセッサモジュールかデバイス選択用に Tools タブをクリックします。

選択した開発モードでのデバイスの inherent limitations についての全情報を
見るには、Details をクリックします。 デバイスのところまでスクロールし、
ダブルクリックして詳細を見ます。None ( 編集のみの ) モードの時はこの操
作は適用できません。

エミュレータがどのデバイスにコンフィギュアされているかを見るには、正
しいツール (MPLAB-ICE または PICMASTER) が選択されているかを確認
し、Inquire をクリックします。 デバイスが Processor ボックスの中に現れ
ます。

Figure 3.5:  開発モードダイアログ開発モードダイアログ開発モードダイアログ開発モードダイアログ

ファームウエアを開発するのに MPLAB IDE を使う時は、下記のモードから
選択して下さい。 

• None ( 編集のみ ) ：ソースコードをライトし、 hex ファイルにアセンブ
ルまたはコンパイルします。プルダウンリストより適切なプロセッサ
を選んで下さい。

• MPLAB-SIM シミュレータ：ソースコードをライトし、 hex ファイルに
アセンブルまたはコンパイルします。そしてシミュレータを介して
PICmicro MCU プログラム実行をシミュレートします。プルダウンリ
ストより適切なプロセッサを選んで下さい。 

• MPLAB-ICE、 PICMASTER、または ICEPIC エミュレータ：ソース
コードをライトし、 hex ファイルにアセンブルまたはコンパイルしま
す。 そしてエミュレータを介して PICmicro MCU プログラム実行をエ
ミュレートします。 MPLAB IDE がハードウエアから適切なプロセッサ
を選択します。 Ports タブをクリックし、ミュレータコミュニケー
ション用に I/O ポートを選択して下さい。
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PICSTART Plus のインストールのインストールのインストールのインストール

• MPLAB-ICD デバッガ： ソースコードをライトし、 hex ファイルにアセ
ンブルまたはコンパイルします。そしてデバッガを介して PICmicro 
MCU コードをデバッグします。プルダウンリストから適切なプロ
セッサを選択して下さい。 Apply をクリックして MPLAB-ICD ダイア
ログを表示し、当てはまるコミュニケーションポートオプションを選
択して下さい。

デバイスにプログラムしたい hex コードがすでにある場合、開発モード用に
Editor Only を選択し、プルダウンリストから、希望するプログラム用プロ
セッサ（デバイス）を選択して下さい。そして OK をクリックして下さい。

MPLAB IDE を使ったファームウエアの開発についてさらに詳しく知りたい
場合は MPLAB IDE User’s Guide を御参照下さい。開発モードを選択し終え
たら OK をクリックします。

3.9  PICSTART Plus の起動の起動の起動の起動
PICSTART Plus を起動するには、PICSTART Plus メニューを選択し、
Enable Programmer (Figure 3.6) をクリックします。プログラマーがイネー
ブルになると、PICSTART Plus デバイスプログラマーダイアログとコン
フィギュレーションビットダイアログが出てきます。これらのダイアログが
出てきたら、  6 章 8 の PICSTART Plus メニュー項目機能の一覧を参考にし
ながら、5 章の PICSTART Plus プログラマーの使い方をお読み下さい。

 

Figure 3.6:  PICSTART Plus Programmer プルダウンメニュープルダウンメニュープルダウンメニュープルダウンメニュー
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他のプログラマー（例えば PRO MATE II 等）を使っている場合は、
PICSTART Plus メニューは使用できないかもしれません。 Options > 
Programmer Options > Select Programmer を選択して Select Programmer ダ
イアログを開き、リストから PICSTART Plus を選択して下さい。プログラ
マーを選択すると MPLAB IDE は注意を促し、それ自体が閉じます。プログ
ラマーオプションが使用できる前に、MPLAB IDE を再スタートさせなけれ
ばなりません。 MPLAB IDE ソフトウエアを再スタートさせると、PICSTART 
Plus メニューがメニューバー上に現れます。 
プログラマーがイネーブルになると、このメニュー項目は Disable 
Programmer に変わり PICSTART Plus をディセーブルするのに使用できま
す。 

MPLAB IDE 内で開発モードをセットアップする時選択したデバイスが
PICSTART Plus オペレーティングシステムによりサポートされない時は、 プ
ログラマーをイネーブルしようとするとメッセージボックスが表示されま
す。

Where possible, PICSTART Plus オペレーティングシステムの前バージョン
には新しいデバイスが提供されます。しかし、新しいデバイスのいくつかは 
PICSTART Plus オペレーティングシステムのアップデートを必要とします。 
オペレーティングシステムのアップグレードの命令は 6 章 9 にリストアップ
されています。アップグレードするには ( サポートされた ) デバイスをプロ
グラムする必要があるため、オペレーティングシステムをアップグレードす
る前に 5 章 3 をお読み下さい。 
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プログラム例プログラム例プログラム例プログラム例

Chapter 4.  プログラム例プログラム例プログラム例プログラム例

4.1  はじめにはじめにはじめにはじめに
この章のチュートリアルでは、下記の PICmicro MCU デバイスをプログラム
する時の手順が示してあります。

• PIC16F84

• PIC12C508A

4.2  例例例例 : Mid-Range PICmicro MCU デバイスのプログラデバイスのプログラデバイスのプログラデバイスのプログラ
ムムムム

この例では、マイクロチップ社の代表的な PICmicro MCU デバイスの一つ、
PIC16F84 をプログラムする手順が示してあります。 

4.2.1 プログラムの全容プログラムの全容プログラムの全容プログラムの全容 – Mid-Range PICmicro MCUデバイデバイデバイデバイ
スススス

ミッドレンジ PICmicro MCU デバイスのプログラムでは次のステップを行い
ます。

• PICSTART Plus 用シリアルポートをコンフィギュアする 
• MPLAB 開発モードをセットアップする l

•  MPLAB プロジェクトとアセンブリーコードを作成する 
• Hex ファイルを組み立てる

• PICSTART Plus をイネーブルする

• PICSTART Plus デバイスプログラマーダイアログをセットアップする

• コンフィギュレーションビットをセットアップする

• デバイスをプログラムする

• プログラムを確認する

4.2.2 始める前に始める前に始める前に始める前に

このチュートリアルを始める前には必ず PICSTART Plus ハードウエア ( セ
クション 3.4) と MPLAB IDE ソフトウエア ( セクション 3.5) をインストール
して下さい。セクション 3.6 から 3.9 までを読み、必ずその指示どうりのス
テップを行ってから始めて下さい。また、PC と PICSTART Plus がつながっ
ていることと、MPLAB メニュー上に PICSTART Plus メニュー項目が表示さ
れていることを、確認してから始める必要があります。 
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4.2.3 MPLAB 開発モードのセットアップ開発モードのセットアップ開発モードのセットアップ開発モードのセットアップ 
開発モードダイアログ ( 図 4.1) を開くために Options > Development Mode 
を選択し、プロセッサーモジュールまたはデバイスを選択して下さい。  
Toolsの画面では、None (編集のみ )を選択して下さい。 PIC16F84 デバイスを
選択し、OK をクリックします。

Figure 4.1:  開発モードのセッティング開発モードのセッティング開発モードのセッティング開発モードのセッティング



 2000 Microchip Technology Inc.                                                                        DS51028C_J-page 27 
　　　　　　　　　　　この日本語ドキュメントは参考資料です。　最新版英語ドキュメントをご参照下さい。　　　　　　　　

　　　　　　　　　　　　　　　　　　　(http://www.microchip.com から入手できます。）

プログラム例プログラム例プログラム例プログラム例

4.2.4 MPLAB プロジェクトとアセンブリーコードの作成プロジェクトとアセンブリーコードの作成プロジェクトとアセンブリーコードの作成プロジェクトとアセンブリーコードの作成

デバイスをプログラムするには、hex ファイルが必要です。この例では、 
MPLAB プロジェクトを使って、自分のソースコードを作成した後 hex ファ
イルにそれをコンパイルします。 

4.2.4.1 プロジェクトの作成プロジェクトの作成プロジェクトの作成プロジェクトの作成

Project > New Project を選択します。新しいプロジェクト psp16f84 に名前を
付け、それを保存したいドライブとディレクトリーを選択します。この例で
は、MPLAB ディレクトリーを使います。OK をクリックします。

Figure 4.2:  プロジェクトの作成プロジェクトの作成プロジェクトの作成プロジェクトの作成

Edit Project ダイアログが表示されます。Editor Only 開発モードと PIC16F84 
デバイスが表示されるはずです。このプロジェクトが作成する hex ファイル
の名前は Project Files の箇所に表示されます。 
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Figure 4.3:  プロジェクトダイアログの編集プロジェクトダイアログの編集プロジェクトダイアログの編集プロジェクトダイアログの編集

hex ファイル psp16f84.hex を選択し、Add Node をクリックします。

Figure 4.4:  アセンブリーファイルを加えるアセンブリーファイルを加えるアセンブリーファイルを加えるアセンブリーファイルを加える
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プログラム例プログラム例プログラム例プログラム例

ファイル名ボックスの中に、psp16f84.asm とタイプして、 OK をクリック
して下さい。 ファイル psp16f84.asm が Edit Project ダイアログの中にある 
プロジェクトファイルリスト内の psp16f84.hex の下に表示されます。OK 
をクリックして Edit Project ダイアログを閉じ、 Project > Save Project を選
択してプロジェクトを保存して下さい。
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4.2.4.2 アセンブリーコードの作成アセンブリーコードの作成アセンブリーコードの作成アセンブリーコードの作成

まだこの時点では、 hex ファイルを作成するためにアセンブルするソース
コードを作成する必要があります。  File > New を選択します。MPLAB デス
クトップ上で Untitled ソースコードウインドウが開きます。 

この例では、sample.asmファイルの中の同じソースコード を使います。 
File > Open を選択して、sample.asmを開いて下さい。これは、標準の 
MPLAB IDE インストールに含まれ、MPLAB ディレクトリーにあります。

Figure 4.5:  sample.asm からソースコードをコピーするからソースコードをコピーするからソースコードをコピーするからソースコードをコピーする

 sample.asmウインドウ内のソースコードをコピーするために MPLAB 
Editor を使用して下さい。そして Untitled ソースコードウインドウを選択し、
その上にコードをペーストして下さい。

Untitled ウインドウにソースコードを入れ終えたら、ファイルを保存します。 
File > Save As を選択し、 psp16f84.asmという名前を記入します。

Figure 4.6:  ソースファイルの保存ソースファイルの保存ソースファイルの保存ソースファイルの保存
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プログラム例プログラム例プログラム例プログラム例

4.2.5 プロジェクトのプロジェクトのプロジェクトのプロジェクトの Hex コードの組み立てコードの組み立てコードの組み立てコードの組み立て

さてここからプロジェクトを組み立て、hex ファイルを作成しましょう。 
Project > Build All を選択して下さい。

Figure 4.7:  Results ウインドウの組み立てウインドウの組み立てウインドウの組み立てウインドウの組み立て

4.2.6 PICSTART Plus の開始の開始の開始の開始

PICSTART Plus をイネーブルするには、 MPLAB メニューから PICSTART 
Plus > Enable Programmer を選択します。プログラマーがイネーブルになる
と、PICSTART Plus デバイスプログラマーダイアログとコンフィギュレー
ションビットダイアログが表示されます。Program Memory も開き、 組み立
てた hex ファイルを表示します。もし Program Memory ウインドウが開か
なければ、Window > Program Memory を選択して開きます。ディスプレイ
上では Program Memory ウインドウのサイズを変えたり移動したりできま
す。Build Results ウインドウを閉じたくなるかもしれません。

Figure 4.8:  イネーブルのイネーブルのイネーブルのイネーブルの PICSTART Plus とデスクトップとデスクトップとデスクトップとデスクトップ
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4.2.6.1 PICSTART Plus デバイスプログラマーダイアログデバイスプログラマーダイアログデバイスプログラマーダイアログデバイスプログラマーダイアログ

PICSTART Plus デバイスプログラマーダイアログは、プログラムしている
過程でずっと開いていなければなりません。 

Figure 4.9:  デバイスプログラマーダイアログデバイスプログラマーダイアログデバイスプログラマーダイアログデバイスプログラマーダイアログ – PIC16F84

デバイス ID は、いったんコードプロテクトされれば、デバイス上のファー
ムウエアのバージョンをトラックするのに便利です。calibration メモリー
チュートリアルはこの特徴を使い、命令を組み入れます ( セクション 4.3.3
を御覧ください )。

全デバイス上でそれらの機能を使うためには、Read、 Blank チェック、 
Program そして  Verify ボタンを使うことになります。  

4.2.6.2 コンフィギュレーションビットダイアログコンフィギュレーションビットダイアログコンフィギュレーションビットダイアログコンフィギュレーションビットダイアログ

プログラマーをイネーブルすると Configuration Bits ダイアログが開きます。
Configuration Bitsダイアログを閉じた場合、  PICSTART Plus デバイスプログ
ラマーダイアログにある Configuration Bits をクリックすれば再び開くこと
ができます。

Figure 4.10:  Configuration Bit のセットのセットのセットのセット
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プログラム例プログラム例プログラム例プログラム例

4.2.6.3 プログラムメモリーウインドウプログラムメモリーウインドウプログラムメモリーウインドウプログラムメモリーウインドウ

MPLAB Program Memory windowは  PIC16F84 デバイスにプログラムしよう
とする hex コードを表示します。Program Memory window が開かない時は、  
Window > Program Memory を選択して開きます。もし Program Memory 
window が図 4.11 のように表示されない時は、システムアイコン ( ウインドウ
のタイトルの左側にある）をクリックして、Hex Code Display を選択して下
さい。ウインドウがソースコードより、 hex 値と ASCII テキストを表示しま
す。

Figure 4.11:  プログラムメモリー内のプログラムメモリー内のプログラムメモリー内のプログラムメモリー内の PIC16F84 コードコードコードコード
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4.2.7 デバイスのプログラムデバイスのプログラムデバイスのプログラムデバイスのプログラム

ここからはプログラムメモリー内にデータがあるので、デバイスのプログラ
ムができます。 PICSTART Plus デバイスプログラマーダイアログの中の
Program をクリックして下さい。ウインドウが進行状況を示し、終了時に
正誤を知らせてきます。

Figure 4.12:   PIC16F84 のプログラムのプログラムのプログラムのプログラム

4.2.8 プログラムを確かめるプログラムを確かめるプログラムを確かめるプログラムを確かめる

デバイス内のプログラムをダブチェックするために、Verify をクリックしま
す。デバイス上のアドレス位置のどれかがプログラムメモリーと符号しない
時には、 エラーログが不一致を表示します。
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プログラム例プログラム例プログラム例プログラム例

4.3  例例例例 : 測定デバイスのプログラム測定デバイスのプログラム測定デバイスのプログラム測定デバイスのプログラム
このセクションの 2 部のチュートリアルには、はじめから測定メモリーを備
えたデバイスをプログラムする過程が示されています。 

この 2部の例では、窓付き PIC12C508A 測定メモリーデバイス を主にプロ
グラムまたは再プログラムするための指示が順を追って示されています。

4.3.1 測定プログラムのプロセスの全容測定プログラムのプロセスの全容測定プログラムのプロセスの全容測定プログラムのプロセスの全容

新しい、プログラムされていない測定メモリーデバイスを主にプログラムす
る過程は次のとうりです。

• PICSTART Plus 用のシリアルポートをコンフィギュアする
• MPLAB 開発モードをセットアップする
• PICSTART Plus をイネーブルする
• デバイスをプログラムするための準備をする

- ファイルに測定データを保存する
- デバイスをチェックし、Device ID または Checksum をセットす
る

- コンフィギュレーションビットのセッティングをチェックする
- Hex ファイルをプログラムされるようロードする

• デバイスをプログラムする
• プログラムを確かめる

消去されたウインドウ測定メモリーデバイスを再プログラムする過程は次の
とうりです。

• PICSTART Plus 用のシリアルポートをコンフィギュアする
• MPLAB 開発モードをセットアップする
• PICSTART Plus をイネーブルする
• デバイスをプログラムするための準備をする

- デバイスをチェックし、Device ID または Checksum をセットす
る

- コンフィギュレーションビットのセッティングをチェックする
- Hex ファイルをプログラムされるようロードする
- ファイルから測定データを再保存する

• デバイスを再プログラムする
• プログラムを確かめる

4.3.2 始める前に始める前に始める前に始める前に

このチュートリアルを始める前には必ず PICSTART Plus ハードウエア ( セ
クション 3.4) と MPLAB IDE ソフトウエア ( セクション 3.5) をインストール
して下さい。セクション 3.6 から 3.9 までを読み、必ずその指示どうりのス
テップを行ってから始めて下さい。また、PC と PICSTART Plus がつながっ
ていることと、MPLAB メニュー上に PICSTART Plus メニュー項目が表示さ
れていることを、確認してから始める必要があります。.
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4.3.3 PIC12C508A 例例例例 パートパートパートパート 1: 窓付き測定メモリーデバイ窓付き測定メモリーデバイ窓付き測定メモリーデバイ窓付き測定メモリーデバイ
スの最初のプログラムスの最初のプログラムスの最初のプログラムスの最初のプログラム

4.3.3.1 MPLAB 開発モードのセットアップ開発モードのセットアップ開発モードのセットアップ開発モードのセットアップ

Development Mode ダイアログ ( 図 4.13) を開くために Options > 
Development Mode を選択して下さい。

Figure 4.13:  Development Mode ダイアログダイアログダイアログダイアログ

MPLAB-SIM Simulator 開発モードを選択した後、PIC12C508A プロセッサー
を選択して下さい。.

4.3.3.24.3.3.24.3.3.24.3.3.2 環境のセッティングの変更環境のセッティングの変更環境のセッティングの変更環境のセッティングの変更

MPLAB IDE 内のデフォルトセッティングにより、ダウンロードした全ての
メモリーが消去されてしまいますが、測定メモリーのデバイスを扱っている
時には、デバイス内にそのメモリーを保存したいので、そうなると困りま
す。そうならないためには、 Options > Environment Setup を選択して下さ
い。 Global Switches エリアを Development Mode ダイアログの General タ
ブ内に定めて下さい。Download チェックボックスの Clear Memory にある
チャックマークをはずして下さい。OK または Apply を選択します。

Note: 測定メモリーを扱う時は、MPLAB IDE がエミュレーターモードにににに
なっていないなっていないなっていないなっていない ことが重要となります。これにより、エミュレータ
からよりもデバイスやファイルから測定データが正しくロードさ
れるのが確実になります。
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プログラム例プログラム例プログラム例プログラム例

4.3.3.3 PICSTART Plus の開始の開始の開始の開始

PICSTART Plus をイネーブルするには、PICSTART Plus メニューから 
Enable Programmer を選択します。

プログラマーがイネーブルになるたびに PICSTART Plus Device 
Programmer ダイアログ(図4.17) とConfiguration Bits ダイアログ (図4.19)が
表示されます。

4.3.3.4 測定データの保存測定データの保存測定データの保存測定データの保存

PIC12C508A のような測定パーツには、プログラムメモリーの特殊なセク
ションに保存された測定パラメターがはじめから備わっています。窓付きデ
バイス (/JW) を再プログラムするために消去する時には、測定データも消去
します。 いったん再プログラムされてからデバイスが正しく動作するために
は個々のデバイスの測定データを再保存しなければなりません。他のデバイ
スの測定データを使うと、デバイスは正確に動作しません。

初めて窓付きデバイスをプログラムする時には、その前に PC の  hex ファ
イルにその測定データを保存します。

このチュートリアルでは、PIC12C508A デバイスを使います。小さなラベル
で番号を付けて下さい。このチュートリアルには、パート “A” と付けましょ
う。

1. PICSTART Plus ソケット内にデバイスを設置する前に、 PICSTART
Plus > Erase Program Memory を選択します。これにより Program
Memory、Data Memory そして Calibration Memory ウインドウにあるす
べてのビットが ‘1’ にセットされます。

2. PICSTART Plus内で “A”とラベルを付けたパーツをインサートします。 
3. デバイスをリードするために、 PICSTART Plus Device Programmer ダ

イアログ内の Read をクリックします。

Figure 4.14:  デバイスをのリードデバイスをのリードデバイスをのリードデバイスをのリード 
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4. デバイスから MPLAB IDE へアップロードされた測定情報を見るため
に、 Window > Calibration Data を選択します。OK をクリックして下さ
い。

Figure 4.15:  測定データ測定データ測定データ測定データ

5. ここからはデバイスの測定データがメモリーの中にあるので、セッティ
ングの名前を作り、後で使用するためにファイルに保存します。File >
Export > Export Memory を選択します。 “Calibration memory” とラベル
されたチェックボックスのみをチェックして下さい。Program
memory、Configuration bits そして IDs check box をクリアにします。今
ソケットの中にあるパーツにファイルを一致できるように、ファイルに
calib-a.hex と名前を付けます。OK をクリックして下さい。

Figure 4.16:  測定データのセーブ測定データのセーブ測定データのセーブ測定データのセーブ

プログラムしたい数個の新しい窓付きパーツがある場合、この手順をそれぞ
れ個別に繰り返して下さい。正しいパーツの後のそれぞれの測定 hex ファイ
ルに名前を付けるのを忘れないで下さい。
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プログラム例プログラム例プログラム例プログラム例

4.3.3.5 Device Programmer ダイアログのセットアップダイアログのセットアップダイアログのセットアップダイアログのセットアップ

PICSTART Plus Device Programmer ダイアログ ( 図 4.17) は PICSTART Plus
がイネーブルの時は常に開いています。この ダイアログを閉じるとプログ
ラマーをディセーブルさせてしまいます。

Figure 4.17:  PICSTART Plus Device Programmer ダイアログダイアログダイアログダイアログ

このデバイスボックスは、開発モードセットアップした時選択した
PIC12C508A デバイスを示します。 

Device ID をクリックして下さい。 0001 と入力して下さい。これによりデバ
イス状のファームウエアのバーションを、プログラムされコードプロテクト
された後に確認することができます。OK をクリックして下さい。

Figure 4.18:  Device ID の使用によるファームウエアまたは他の情報の確認の使用によるファームウエアまたは他の情報の確認の使用によるファームウエアまたは他の情報の確認の使用によるファームウエアまたは他の情報の確認
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4.3.3.6 Configuration Bits ダイアログのセットアップダイアログのセットアップダイアログのセットアップダイアログのセットアップ

Configuration Bits ダイアログ ( 図 4.19) は PICSTART Plus がイネ－ブルにな
ると開きます。Configuration Bits ダイアログを閉じていたら、 PICSTART 
Plus Device Programmerダイアログ内のConfiguration Bits をクリックして
再び開いて下さい。

Figure 4.19:  Configuration Bits ダイアログダイアログダイアログダイアログ – PIC16F84

コンフィグレーション用のデフォルト値を使います。Code Protect がオフに
なっているのを確認して下さい。

4.3.3.7 プログラム用にプログラム用にプログラム用にプログラム用に Hex ファイルをロードするファイルをロードするファイルをロードするファイルをロードする

ここからは、もう hex ファイルに測定データを保存してあるので、プログラ
ムできるようにファイルをロードします。  MPLAB Program Memory ウイン
ドウに hex コードをロードするために、File > Import > Import to Memory を
選択します。   12c508a.hexを選んで下さい。MPLAB のインストールに含
まれています。 

Figure 4.20:  Download Emulation Memory ダイアログダイアログダイアログダイアログ
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プログラム例プログラム例プログラム例プログラム例

この時点で、Program Memory ウインドウに hex ファイル ( 図 4.21) からの
hex コードが入っているはずです。 Program Memory ウインドウが開いてい
ない時は、Window > Program Memoryt を選択して開いて下さい。

Figure 4.21:  Program Memory 内の内の内の内の 12c508a.hex  – Hex コード表示コード表示コード表示コード表示
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4.3.3.8 測定デバイスのプログラム測定デバイスのプログラム測定デバイスのプログラム測定デバイスのプログラム

全デバイス ( プログラムメモリー、コンフィギュレーションビット等の全
て）をプログラムするために、PICSTART Plus Device Programmer ダイア
ログ内の Program をクリックして下さい。 

Figure 4.22:  PIC12C508A のプログラムのプログラムのプログラムのプログラム

デバイスがプログラムされている間は、Program/Verify ダイアログ が表示さ
れます。プログラムされる領域は、そのデバイスに応じて自動的に選択され
ます。

プログラムが終了すると、“Success” または “Failure” が Start Address の右
側に表示されます。プログラム実行が失敗すると、プログラムしようとした
各々のアドレスに対して正しいデータ（期待値）とエラーデータ（実際値）
が示されたエラーウインドウが表示されます。
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プログラム例プログラム例プログラム例プログラム例

4.3.3.9 プログラムのベリファイプログラムのベリファイプログラムのベリファイプログラムのベリファイ

デバイスのプログラムが終了したので、PICSTART Plus Device  
Programmer ダイアログ内の Verify をクリックして、デバイスのコンテンツ
が Program Memory ウインドウ内と PICSTART Plus Device Programmer ダ
イアログ内に示された値と一致しているかどうかをベリファイして下さい。

Figure 4.23:  プログラムのベリファイプログラムのベリファイプログラムのベリファイプログラムのベリファイ 
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4.3.4 PIC12C508A 例例例例 ポートポートポートポート 2: 窓付き測定メモリーデバイ窓付き測定メモリーデバイ窓付き測定メモリーデバイ窓付き測定メモリーデバイ
スの再プログラムスの再プログラムスの再プログラムスの再プログラム

4.3.4.1 始める前に始める前に始める前に始める前に

セクション 4.3.3 に載っている窓付きデバイスの最初のプログラム用の
チュートリアルを終了してから、このチュートリアルを御使用下さい。

窓付きパーツを再プログラムする前には、必ず UV イレーザーで消去して下
さい。デバイスの窓の部分に付いているカバーを取り外します。パーツを 
UV イレーザーの中に入れます。  UV 消去可能なデバイスを完全に消去する
のに必要な時間は、光の波長、光の強度、 UV ソースからの距離、そのデバ
イスのプロセス技術 ( メモリーセルの容量 ) により決まります。これにより、
測定メモリーを含む全デバイスが消去されます。 正確に動作させるには、以
前にチップ用に作成した測定ファイルを取り入れることにより、デバイスに
対応する測定メモリーを保存しておく必要があります。 

4.3.4.2 Device Programmer ダイアログのセットアップダイアログのセットアップダイアログのセットアップダイアログのセットアップ

一つ前のチュートリアル ( セクション 4.3.3) でパーツを最初にプログラムし
た時、中にプログラムを書き込んだファームウエアのバージョンを見失わな
いようにデバイス ID を設定しました。このチュートリアルの第一段階では、
その番号をアップデートします。PICSTART Plus Device Programmer ダイ
アログ内の Device ID をクリックします。0002 と入力して下さい。 自分の
コードのバーション 2 をプログラムしようとしていることを指示するためで
す。これによりプログラムされてコードプロテクトされた後でも、デバイス
のファームウエアのバージョンを確認することができます。

Figure 4.24:  ファームウエアまたは他の情報のファームウエアまたは他の情報のファームウエアまたは他の情報のファームウエアまたは他の情報の Device ID の使用による確認の使用による確認の使用による確認の使用による確認
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プログラム例プログラム例プログラム例プログラム例

4.3.4.3 Configuration Bits ダイアログのセットアップダイアログのセットアップダイアログのセットアップダイアログのセットアップ

Configuration Bits ダイアログは PICSTART Plus がイネ－ブルになると開き
ます。Configuration Bits ダイアログを閉じていたら、 PICSTART Plus 
Device Programmer ダイアログ内の Configuration Bits をクリックして再び
開いて下さい。

Figure 4.25:  Configuration Bits ダイアログダイアログダイアログダイアログ – PIC16F84

コンフィグレーション用のデフォルト値を使います。Code Protect がオフに
なっているのを確認して下さい。
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4.3.4.4 プログラム用にプログラム用にプログラム用にプログラム用に Hex ファイルをロードするファイルをロードするファイルをロードするファイルをロードする

プログラムメモリーにデバイスの測定データをロードする前に、プログラム
用にファイルをロードして下さい。

MPLAB Program Memoryウインドウにhex コードをロードするために File > 
Import > Import to Memory を選択して下さい。12c508a2.hexを選択しま
す。これはパーツをプログラムするのに初めから使ったプログラムに似てい
ますが、 この手順を行うのに少し変更されています。

Program Memory ウインドウには、この段階で hex ファイルからの hex コー
ドがあるはずです。Program Memory ウインドウが開いていない時は、  
Window > Program Memory を選択して開いて下さい。

Figure 4.26:  Program Memory – Hex コード表示コード表示コード表示コード表示
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プログラム例プログラム例プログラム例プログラム例

4.3.4.5 デバイスへの測定値の再保存デバイスへの測定値の再保存デバイスへの測定値の再保存デバイスへの測定値の再保存

以前にパーツの測定データを hex ファイル calib-a.hexに保存しました。
UV eraser がそのデータをデバイスから消去したので、デバイスに再びライ
トして再プログラムされたパーツが正確に動作するようにします。

1.  File > Import > Import to Memory を選択し、セーブされた測定パラメー
タファイル (calib-a.hex) を選択して下さい。

Figure 4.27:  消去されたデバイスに測定データを再保存する消去されたデバイスに測定データを再保存する消去されたデバイスに測定データを再保存する消去されたデバイスに測定データを再保存する 

2. MPLAB IDE 内のデフォルトセッティングにより、ダウンロードした全
てのメモリーが消去されてしまいますが、測定メモリーのデバイスを
扱っている時には、デバイス内にそのメモリーを保存したいので、そう
なると困ります。そうならないためには、 Options > Environment Setup
を選択して下さい。 Global Switches エリアを Development Mode ダイ
アログの General タブ内に定めて下さい。 Download チェックボックス
の Clear Memory にチェックマークが 付いていない付いていない付いていない付いていないことを確認して下
さい。OK をクリックして下さい。

4.3.4.6 測定デバイスのプログラム測定デバイスのプログラム測定デバイスのプログラム測定デバイスのプログラム

PICSTART Plus Device Programmer ダイアログの Program をクリックしま
す。これによりプログラムメモリー、測定メモリー、コンフィギュレーショ
ンビット等の全デバイスをプログラムできます。

デバイスがプログラムされている間は、Program/Verify ダイアログ が表示さ
れます。プログラムされる領域は、そのデバイスに応じて自動的に選択され
ます。

プログラムが終了すると、“Success” または “Failure” が Start Address の右
側に表示されます。
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4.3.4.7 Verifying the Programming

デバイスのプログラムが終了したので、PICSTART Plus Device  
Programmer ダイアログ内の Verify をクリックして、デバイスのコンテンツ
が Program Memory ウインドウ内と PICSTART Plus Device Programmer ダ
イアログ内に示された値と一致しているかどうかをベリファイして下さい。
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PICSTART® PLUS USER’S GUIDE12
Chapter 5.  PICSTART Plus の使用の使用の使用の使用 

5.1  はじめにはじめにはじめにはじめに
この章には PICSTART Plus 開発プログラマーを使ったプログラムやリード
を行う時に必要な手順が書いてあります。

5.2  ポイントポイントポイントポイント
この章で扱う項目は下記のとうりです。

• デバイスをプログラムする手順

• プログラムの確認

• デバイスのリード

5.3  デバイスをプログラムする手順デバイスをプログラムする手順デバイスをプログラムする手順デバイスをプログラムする手順
デバイスをプログラムするには下記のものが必要です。

• PICmicro MCU デバイスにプログラムするための hex ファイル 

• プログラム用のブランクの PICmicro MCU デバイス

プログラムを行う前には下記の準備が必要です。

• PICSTART Plus ハードウエアとMPLAB IDE ソフトウエア (第3章)のイ
ンストール

• PICSTART Plus と PC 間のコミュニケーションの確立

• MPLAB IDE 開発モードのセットアップ

• PICSTART Plus ( セクション 3.9) のイネーブル ( 開始 )

次の表は、デバイスをプログラムするステップです。.

ステッステッステッステッ
ププププ

詳細詳細詳細詳細 参照するセクション参照するセクション参照するセクション参照するセクション

1 Device Programmer ダイアログのセット
アップ

セクション 5.3.1 

2 Configuration Bits ダイアログのセット
アップ

セクション 5.3.2

3 プログラムメモリーへの hex ファイルの
ロード、またはソースコードからのファ
イルのアセンブル / コンパイル 

セクション 5.3.3

4 デバイスがブランクであることの確認 セクション 5.3.5
5 デバイスのプログラム セクション 5.3.6



PICSTART® Plus User’s Guide

DS51028C_J-page 50                                                        2000 Microchip Technology Inc.  
　　　　　　　　　　この日本語ドキュメントは参考資料です。　最新版英語ドキュメントをご参照下さい。　　　　　　　　　

　　　　　　　　　　　　　　　　　　(http://www.microchip.com から入手できます）

5.3.1 Device Programmer ダイアログのセットアップダイアログのセットアップダイアログのセットアップダイアログのセットアップ

PICSTART Plus がイネーブルの時は、PICSTART Plus Device Programmer 
ダイアログ ( 図 5.1) は常に開いています。 このダイアログを閉じるとプログ
ラムがディセーブルとなります。

Figure 5.1:  PICSTART Plus Device Programmer ダイアログダイアログダイアログダイアログ

デバイスリストは、MPLAB IDE 開発モードをセットアップした時に選択さ
れたデバイスを示しています。 もし他のデバイスをプログラムしたいなら、
ここからまたは Options > Development Mode から選択しますが、この時点
でデバイスを変更すると、開いている全ての MPLAB IDE プロジェクト 
(Editor Only モードになっていれば例外ですが ) が閉じられて、プログラムメ
モリー、コンフィギュレーションビット、ID ロケーションが消去されてし
まいます。 
もしデバイスが PICSTART Plus Device Programmer ダイアログに載ってい
ない時には 、MPLAB IDE ソフトウエアの今のバージョンと、おそらく
PICSTART Plus オペレーティングシステム ( セクション 6.9) の今のバージョ
ンをアップグレードする必要があります。

コンフィギュレーションビットは、次のセクションに載っている
Configuration Bits ダイアログにセットされています。もし Configuration Bits 
ダイアログを閉じた場合、 このダイアログ内の Configuration Bits をクリッ
クすれば再び開くことができます。

Device ID をクリックすることにより、デバイス ID 値を編集したり、プロテ
クトされていないチェックサムをプログラムできます。  Program Statistics
をリセットするには、Reset をクリックします。 Voltages セクションは電圧
をデフォルトするようセットされており、変更することはできません。
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PICSTART Plus の使用の使用の使用の使用

5.3.2 Configuration Bits ダイアログのセットアップダイアログのセットアップダイアログのセットアップダイアログのセットアップ

Configuration Bits ダイアログ (図5.2)はPICSTART Plusがイネーブルの時開
きます。Configuration Bits ダイアログを閉じても PICSTART Plus Device 
Programmer ダイアログ内の Configuration Bits をクリックすると再び開く
ことができます。

Figure 5.2:  Configuration Bits ダイアログダイアログダイアログダイアログ – PIC16C74A

ここに載っている configuration bits は PIC16C74A デバイス用です。 コン
フィギュレーションビットの型と番号は選んだデバイスによって異なりま
す。使用するデバイス用のコンフィギュレーションビットについては、より
詳しい機能の説明がデバイスのデータシートに載っていますので御参照下さ
い。

コンフィギュレーションビット値は、Configuration Bits ダイアログに入れる
かわりにソースコードに記入することができます。MPASM’s _ _CONFIG 
指示を使い、デバイスのコンフィギュレーションビットがプログラムされる
ようにセットして下さい。 プロジェクトを再ビルドしたり、hex ファイルを
再ロードするたびに、コンフィギュレーションビットはこの指示の値に従っ
てセットされます。 
ソースコードにコンフィギュレーションビットをセットしないと、これらの
ビットは変更できません。 このダイアログを使ってこれらのビットのデフォ
ルト値を手動で変更すると、その値はマイクロコントローラーをプログラム
する時に PICmicro MCU デバイスの中にプログラムされます。 

Edit ID ダイアログ内にセットされる ID 値はプログラムにセットされている
どの値も無効にします。 

Note: Configuration Bits ダイアログ内のコンフィギュレーションビット
をセットしても、エミュレーターまたはシュミレーターの作動を
変更することはできません。 変更するには、Options > Develop-
ment Mode を使用して下さい。
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5.3.3 Program Memory へへへへ Hex ファイルをロードするファイルをロードするファイルをロードするファイルをロードする

Program Memory についてについてについてについて

PICSTART Plus がイネーブルになると、Program Memory ウインドウは、
まだ開いていない場合は Hex Code フォーマットに開きます。

Program Memory は hex コード、マシーンコード、または記号に分解された
もの（もし利用できれば）として見ることができます。 ディスプレーモード
を変更するには、ウインドウの左上端にあるシステムボタンをクリックし、
システムメニューからディスプレーモードを選択します。

MPLAB-ICE エミュレータモードの時、Program Memory は MPLAB-ICE 
ポッドのエミュレーションメモリーにあるデータを示します。このメモリー
は、エミュレータを使い run、single step、または trace を行う時に MPLAB-
ICE probe によってリードされます。

MPLAB-SIM シミュレータモードまたは Editor Only モードの時、Program 
Memory ウインドウは PC 上のメモリーバッファーの内容を表します。この
メモリーは、run、single step、または trace を行う時に MPLAB-SIM によっ
てリードされます。 
エミュレータモードまたはシミュレータモードの時に PICSTART Plus を
使ってプログラムメモリーをリードすると、エミュレートまたはシミュレー
トされたプログラムメモリーがオーバーライトされてしまいます。MPLAB 
IDE プロジェクトが開いている場合には、この状態がプログラムメモリーと
デバッグ情報の間に“不適合”を起こすことがあります。このような場合に
は MPLAB IDE プロジェクトを閉じるか、このまま続けて Program Memory 
ウインドウにデバイスのメモリーをリードして下さい。次のデバッグ動作は
正しく動かない可能性があります。
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PICSTART Plus の使用の使用の使用の使用

Program Memory にににに Hex ファイルをロードするファイルをロードするファイルをロードするファイルをロードする

PICmicro MCUにプログラムできるhex ファイル (例えば code.hex等 )があ
れば、 File > Import > Import to Memory を選んで MPLAB IDE の Program 
Memory にその hex コードをロードして下さい。Import Emulation Memory ダ
イアログの左下にある Hex file タイプを選び、ドライブとディレクトリーを
ブラウズして、その hex ファイルの位置を定めて下さい。そしてその hex 
ファイルを選び、OK をクリックします ( 図 5.3 を御参照下さい )。

Figure 5.3:  Import Emulation Memory ダイアログダイアログダイアログダイアログ

Program Memory ウインドウには、この時点で hex ファイル ( 図 5.4) からの 
hex コードが表示されているはずです。 もし Program Memory ウインドウが
開いていない場合は、 Window > Program Memory を選択して開いて下さい。
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Figure 5.4:  Program Memory – Hex コード表示コード表示コード表示コード表示

デバイスをプログラムするための hex ファイルを持っていない場合は、  
MPLAB Projects を使って組み立てることができます。MPLAB IDE User’s 
Guide には、ユーザーがファームウエアの開発用に MPLAB Projects を使用す
る時に参考になるいくつかのチュートリアルが載っています。 プロジェクト
をリビルドするたびに Program Memory ウインドウはアップデートされま
す。 

5.3.4 PICSTART Plus で使用するで使用するで使用するで使用する File フォーマットフォーマットフォーマットフォーマット 
PICSTART Plus は途中にどんな操作も必要とせずに、直接 MPLAB IDE プロ
ジェクトから情報を使用することができます。 MPASM は MPLAB IDE とは
別に操作でき、PICSTART Plus 用の hex ファイルを作成できます。あるい
はまた、デバイスはどんな PICmicro MCU コンパチブルクロスアセンブラー
またはクロスコンパイラーからの hex ファイルでもプログラムすることがで
きます。

MPLAB IDEとは別にMPASMを使っている場合、またはPICSTART Plusと一
緒に使うための hex ファイルを作るのに MPLAB IDE を使っている場合、 必
ず INHX8M または INHX32 hex フォーマットを使用して下さい。hex ファイ
ル用の MPASM のデフォルトアウトプットフォーマットは INHX8M です。
もし PIC17CXXX または PIC18CXXX デバイスをプログラムしているなら
ば、 INHX32 フォーマットを使う必要があります。 ファイルフォーマットに
関する詳しい説明は MPASM User’s Guide with MPLINK and MPLIB を御参
照下さい。



 2000 Microchip Technology Inc. 　　　　　　　　　　　　　　　　　　　DS51028C_J-page 55
　　　　　　　　　　この日本語ドキュメントは参考資料です。　最新版英語ドキュメントをご参照下さい。　　　　　　　　　

　　　　　　　　　　　　　　　　　　　(http://www.microchip.com から入手できます）

PICSTART Plus の使用の使用の使用の使用

5.3.5 ブランクのデバイスをチェックするブランクのデバイスをチェックするブランクのデバイスをチェックするブランクのデバイスをチェックする

プログラムするデバイスを PICSTART Plus ソケットにはめ込みます。 ソ
ケットの左側にある ‘ １ ’ で示されたピン１の位置にデバイス上のピン１を
入れて下さい。自分の方に ( 上に ) ソケットの上の銀色のレバーを引き、デ
バイスをしっかり固定します。

PICSTART Plus Device Programmer ダイアログの Blank をクリックし、デ
バイスが完全にブランク ( 全てのビットが ‘1’ にセットされている ) であるこ
とを確かめます。これにより全てのコンフィギュレーションビットが ‘1’ ( プ
ログラムされていない状態 ) であることも確かめられます。また  MPLAB メ
ニューから PICSTART Plus > Blank Check All を選んでブランクチェックを
行うこともできます。

ワンタイムプログラマブル (OTP) デバイスを使う場合、コンフィギュレー
ションビットのいくつかが生産時に既にプログラムされていることがありま
す ( 例えば oscillator ビット等 )。Configuration Bits ダイアログを使い、コン
フィギュレーションビットを生産時のセッティングにセットし、PICSTART 
Plus > Blank Check OTP を選択して下さい。これにより全てのプログラムメ
モリービットが ‘1’ にセットされていること、そしてコンフィギュレーショ
ンビットがダイアログ内の値と一致していることがチェックできます。OTP 
デバイスは消去および再プログラムすることができません。

EPROM デバイスがブランクでない場合、プログラム前に消去を行う必要が
あります。窓付きデバイスの消去は下記の手順に従って下さい。

1. デバイスの窓に付いているラベルなどをすべて取り除きます。窓付きデ
バイス ( 図 5.5) をお持ちでない場合は 再プログラムはできません。 窓
付きバージョンの EPROM デバイスはすべて JW パッケージを御請求
下さい。

Figure 5.5:  窓付きデバイス窓付きデバイス窓付きデバイス窓付きデバイス

2. 紫外線 (UV) EPROM Eraser にデバイスを入れます。 UV 消去可能デバ
イスを完全に消去するのに必要な時間は、光の波長、 光の強度、UV 源
からの距離、デバイスのプロセス技術 ( メモリーセルの大きさ ) によっ
て異なります。

3. デバイスをプログラムする前にブランクチェックを再び行い、それがブ
ランクであることを確認して下さい。

デバイスが EEPROM/FLASH の場合は、再プログラムの前に消去する必要
がありません。これらのデバイスは、プログラム前に電気的な消去が行われ
るからです。
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5.3.6 デバイスのプログラムデバイスのプログラムデバイスのプログラムデバイスのプログラム

デバイス全体 ( すなわちプログラムメモリー、コンフィギュレーションビッ
ト等のすべて）のプログラムを行うには、PICSTART Plus Device 
Programmer ダイアログ内の Programi をクリックして下さい。

選択的に ( 例えばプログラムメモリーの一部、コンフィギュレーションのみ
等 ) プログラムを行うには、 PICSTART Plus > Program/Verify を選択して、
Program/Verify ダイアログ (図 5.6)を開いて下さい。そしてプログラム用にオ
プションを選択し、Program/Verify ダイアログ内の Program をクリックし
てデバイスをプログラムします。

 

Figure 5.6:  Program/Verify ダイアログダイアログダイアログダイアログ

MPLAB IDE に見られる値とデバイスの内容を比較するには Verify をクリッ
クします。 Close をクリックするとダイアログが閉じます。

選択的にプログラムを行うには、Program/Verify ダイアログ内の下記のセッ
ティングを調整する必要があります。チェックボックスに印が付いているメ
モリー領域がプログラムされます。グレーで示されている部分の領域はその
デバイスでは使用できません。 .

Start Address プログラムやベリファイ用のプログラムメモ
リー内の開始のアドレス。

End Address プログラムやベリファイ用のプログラムメモ
リー内の終わりのアドレス。

Program Memory Start AddressとEnd Addressにより記された範
囲のプログラムメモリーをプログラムまたはベ
リファイします。 

Configuration Bits コンフィギュレーションビットをプログラムま
たはベリファイします。
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PICSTART Plus の使用の使用の使用の使用

5.4  プログラムのベリファイプログラムのベリファイプログラムのベリファイプログラムのベリファイ
PICSTART Plus Device Programmer ダイアログまたは Program/Verify ダイ
アログ内の Verify をクリックして、デバイスの内容がプログラムメモリー、
EEPROM データ、測定メモリー、 ID 位置、そして MPLAB IDE と 
PICSTART Plus Device Programmer ダイアログそして Configuration Bits ダ
イアログ内のコンフィギュレーションビットに一致しているかどうかを確か
めます。 

ID Locations ID 位置をプログラムまたはベリファイします。
PICSTART Plus Device Programmer ダイアロ
グを使い ID 位置をセットできます。

EEPROM Data データ EEPROM を備えたデバイスでは、
EEPROM Memory ウインドウ内のデータの
データメモリーをプログラムまたはベリファイ
します。 データ EEPROM と EEPROM Mem-
ory ウインドウに関する詳しい説明については
MPLAB IDE User’s Guide を御参照下さい。

Calibration Memory 測定メモリーを備えたデバイスでは、  Calibra-
tion Memory ウインドウ内のデータの測定メモ
リーをプログラムまたはベリファイします。測
定メモリーと Calibration Memory ウインドウ
に関する詳しい説明については MPLAB IDE 
User’s Guide を御参照下さい。

Code Protect Settings 選択されたデバイス用にコードプロテクトの状
態と有効性を示します。
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5.5  デバイスをリードするデバイスをリードするデバイスをリードするデバイスをリードする
ファームウエアをプログラムされた PICmicro MCU デバイスからプログラム
されていないデバイスへコピーするには、まずプログラムされたファームウ
エア ( プログラムメモリー、コンフィギュレーションビット等 ) を MPLAB 
IDE に読みとり、それからこの情報に基づいて新しいデバイスをプログラム
します。

デバイス全体 ( 例えば全プログラムメモリー、コンフィギュレーションビッ
ト等 ) をリードするには、PICSTART Plus Device Programmer ダイアログ
内の Read をクリックして下さい。

選択的に ( 例えばプログラムメモリーの一部、コンフィギュレーションビッ
トのみ等 ) リードを行うには、 PICSTART Plus > Read Device を選択して to 
Read Device ダイアログ (図5.7)を表示します。 リードするためにオプション
を選択し、デバイスをリードするために Read Device ダイアログ内の Read 
をクリックして下さい。チェックボックスと一致するメモリー領域がリード
されます。 グレーで示されている部分はこのデバイスでは使用できません。 
Close をクリックするとダイアログが閉じます。

Figure 5.7:  Read Device ダイアログダイアログダイアログダイアログ

選択的にリードを行うには、Read Device ダイアログ内で下記のセッティン
グを調整して下さい。 

Start Address リード用のプログラムメモリー内の開始のアド
レス。

End Address リード用のプログラムメモリー内の終わりのア
ドレス。

Program Memory Start Address とEnd Addressにより記された領
域用のプログラムメモリーをリードします。

Configuration Bits コンフィギュレーションビットをリードしま
す。

ID Locations ID ロケーションをリードします。
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PICSTART Plus の使用の使用の使用の使用

リードが一度完了すると、Program Memory ウインドウはデバイスマスター
からリードされたデータを表示するので、ここからは下記の３点が可能にな
ります。

• hex ファイルにセーブする前または他のデバイスをプログラムする前
に Window > Modify を選択して、MPLAB IDE 内のデータの変更を行
う 

• File > Export > Export Memory を選択して、hex ファイルとしてデータ
をセーブする

• データを中にコピーするために、PICSTART Plus 内に新しいデバイス
を取り付ける

デバイスをリードしようとして何か問題が生じた場合は、付録 C を御参照
下さい。

EEPROM  Data データ EEPROM を備えたデバイスでは、デー
タメモリー内のデータを EEPROM Memory ウ
インドにリードします。 データ EEPROM と 
EEPROM Memory ウインドウに関する詳しい
説明については MPLAB IDE User’s Guide を御
参照下さい。

Calibration Memory 測定データを備えたデバイスでは、測定メモ
リー内のデータを Calibration Memory ウイン
ドウにリードします。測定メモリーと Calibra-
tion Memory ウインドウに関する詳しい説明に
付いては MPLAB IDE User’s Guide を御参照下
さい。

Note: IMPLAB IDE に接続する MPLAB-ICE エミュレータを使う場合、
コードが MPLAB-ICE のエミュレートされたプログラムメモリー
にダウンロードされます。プロジェクトがオープンならば、デバ
イスからメモリーをリードする前にそれを閉じるかどうか質問さ
れます。プロジェクトを開いたままだと、Absolute Listing ウイン
ドウと Source Code ウインドウが、Program Memory ウインドウ
にリードしたデータと一致しないことがあります。Program Mem-
ory ウインドウ内の正しいアドレスにシンボルが一致しないかも
しれません。
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NOTES:
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PICSTART® PLUS USER’S GUIDE12
Chapter 6.  PICSTART Plus – リファレンスリファレンスリファレンスリファレンス

6.1  はじめにはじめにはじめにはじめに
この章は、PICSTART Plus 開発システムのダイアログ、ウインドウ、メ
ニュー項目について書いてあります。

6.2  ポイントポイントポイントポイント
この章で扱う項目は次のとうりです。

• PICSTART Plus Device Programmer ダイアログ

• Configuration Bits ダイアログ

• Program Memory ウインドウ

• Program/Verify ダイアログ

• Read Device ダイアログ

• PICSTART Plus メニュー項目

• PICSTART Plus オペレーティングシステムのアップグレード
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6.3  PICSTART Plus Device Programmer ダイアログダイアログダイアログダイアログ
PICSTART Plus Device Programmer ダイアログ (図 6.1) はプログラマーがイ
ネーブルの時はいつも表示されます。PICSTART Plus Device Programmer  
ダイアログを閉じるとプログラマーがディセーブルとなります。ダイアログ
内のオプションは動作していればその時点の値を示し、そうでなければディ
セーブル ( グレーで示されます ) となります。Voltage の部分では電圧をデ
フォルトにするようセットされており、変更できません。

 

Figure 6.1:  PICSTART Plus Device Programmer ダイアログダイアログダイアログダイアログ

デバイスをプログラムするには、PICSTART Plus Device Programmer ダイ
アログ内の次のオプションをセットする必要があります。 

Device PICmicro MCU デバイスタイプをセットして、PIC-
START Plus と一緒に使います。開発モードをセッ
トアップした時選択したデバイスはデフォルトで
す。

Note: ここでデバイスタイプをセットすると、
開いている全ての MPLAB IDE プロジェ
クト (Editor Only モードのものは除く )が
閉じ、プログラムメモリー、コンフィギュ
レーションビット、 ID locations が消去さ
れます。
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PICSTART Plus – リファレンスリファレンスリファレンスリファレンス

ID とととと Checksum Device ID をクリックして Edit ID ダイアログを開
き、ID 値のエディット、またはプロテクトされて
いないチェックサムのデバイスへのプログラムを
行います。

Figure 6.2:  Edit ID ダイアログダイアログダイアログダイアログ

もし特定の ID 値をプログラムするならば、 User 
Entry を選択し ID用の 4または 8 digitの hex 値を入
力します。デバイス用の ID 値にプロテクトされて
いないチェックサムを自動的にプログラムするに
は、Unprotected CheckSum を選択します。 OK を
クリックしてオプションをセットするか、ID オプ
ションをセットせずに Cancel をクリックして 
PICSTART Plus Device Programmer ダイアログに
戻ります。

 _ _IDLOCS 命令を使い ID バイトをセットする
こともできます。プロジェクトを再ビルドしたり
hex ファイルを再ロードする時はいつも ID ロケー
ションがこの命令の値に応じてセットされます。

Edit ID ダイアログ内にセットされた ID 値はプログ
ラムにセットされたどの値をも上書きします。

Program Statistics 正しい (Pass) また正しくない (Fail) プログラム例
の数とトータル数を示します。Reset をクリック
してカウンターのリセットをして下さい。

Voltages デフォルトの電圧を示します。Voltages 部分はデ
電圧をデフォルトにセットするためのもので、変
更できません。

Close PICSTART Plus Device Programmer ダイアログを
閉じ、プログラマーをディセーブルにします。

SQTP File Serialized Quick Turn Production (SQTPSM) プログ
ラムは、PICSTART Plus では使用できません。
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6.4  Configuration Bits ダイアログダイアログダイアログダイアログ
Configuration Bits ダイアログ ( 図 6.3) はプログラマーがイネーブルの時は常
に表示されます。 Configuration Bits ダイアログを閉じた場合、PICSTART 
Plus Device Programmer ダイアログ内のConfiguration Bitsをクリックする
と再び開くことができます。 Configuration Bits ダイアログにリストされてい
るビットは選択したデバイスによって決まります。

Figure 6.3:  Configuration Bits ダイアログダイアログダイアログダイアログ

Blank デバイスが完全にブランク ( 全てのビットが ‘1’ に
セットされている ) であることを確認します。こ
れにより全てのコンフィギュレーションビットが
‘1’ ( プログラムされていない状態 ) にセットされて
いることも確認できます。

Read 全てのプログラムメモリー、コンフィギュレー
ションビット、ID ロケーション、EEPROM デー
タ、デバイスの測定メモリーをリードします。

Program 全てのプログラムメモリー、コンフィギュレー
ションビット、ID ロケーション、EEPROM デー
タ、デバイスの測定メモリーをプログラムします。

Verify デバイス上のプログラムが MPLAB IDE と PIC-
START Plus Device Programmer ダイアログ内のプ
ログラムメモリー、コンフィギュレーションビッ
ト、ID ロケーション、EEPROM、測定メモリーに
一致するかどうか確認します。
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PICSTART Plus – リファレンスリファレンスリファレンスリファレンス

6.5  Program Memory ウインドウウインドウウインドウウインドウ
PICSTART Plus がイネーブルの時、Program Memory ウインドウはまだ開い
ていなければ Hex Code フォーマットで開きます。

MPLAB-ICE エミュレータモードでは、Program Memory は MPLAB-ICE ポッ
ドのエミュレーションメモリーにあるデータを示します。このメモリーは、
エミュレーターを使ってラン、シングルステップ、トレースを行う時に
MPLAB-ICE プローブによってリードされます。

シミュレータモードまたはエディターオンリーモードでは、Program 
Memory ウインドウはPC上のメモリーバッファーの内容を表します。 このメ
モリーはラン、シングルステップ、トレースを行う時 MPLAB-SIM によって
リードされます。

エミュレータモードまたはシミュレータモードの時に PICSTART Plus を
使ってプログラムメモリーをリードする場合、 エミュレートまたはシミュ
レートされたプログラムメモリーを上書きします。もし MPLAB IDE プロ
ジェクトを開いたままこれを行うと、プログラムメモリーとデバッグ情報の
間で “ 不一致 ” を起こすことがあります。 この場合、この時点で開いている
MPLAB IDE プロジェクトを閉じるか、または Program Memory ウインドウ
にデバイスのメモリーをリードし続けるのどちらかの操作を選んで下さい。
この後のデバッグ動作が正しく行われないかもしれません。

Figure 6.4:  Program Memory ウインドウウインドウウインドウウインドウ

Program Memory は hex コード、マシーンコードまたはシンボルによって分
解されたもの ( 有効であれば ) から成っているのがわかります。システムボ
タンをクリックし、システムメニューよりディスプレーオプションを選択し
てディスプレーモードを変更して下さい。 
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6.6  Program/Verify ダイアログダイアログダイアログダイアログ
選択的にプログラムやベリファイを行うには ( 例えば、プログラムメモリー
の一部、コンフィギュレーションビットのみ等 )、 PICSTART Plus > 
Program/Verify を選択して Program/Verify ダイアログ ( 図 6.5) を開いて下さ
い。 

Figure 6.5:  Program/Verify ダイアログダイアログダイアログダイアログ

プログラムまたはベリファイ用にオプションを選択して下さい。そしてこの
ダイアログの Program をクリックしデバイスをプログラムします。チェッ
ク印の付いたボックスに一致するメモリー領域がプログラムされることにな
ります。グレーで示されている部分はこのデバイスでは使用できません。  

Verify をクリックし、デバイスのプログラムがプログラムメモリー、コン
フィギュレーションビット、  ID ロケーション、EEPROM、そして MPLAB 
IDE とPICSTART Plus Device ProgrammerダイアログとConfiguration Bits ダ
イアログ内にある測定メモリー値に一致するかどうかを確認します。

Start Address プログラムメモリー内にあるプログラム用または
ベリファイ用の開始のアドレス。

End Address プログラムメモリー内にあるプログラム用または
ベリファイ用の終わりのアドレス。

Program Memory Start Address とEnd Addressにより指定された領
域のプログラムメモリーをプログラムまたはベリ
ファイします。

Configuration Bits コンフィギュレーションビットをプログラムまた
はベリファイします。

ID Locations ID ロケーションをプログラムまたはベリファイし
ます。PICSTART Plus Device Programmer ダイ
アログを使い ID ロケーションをセットできます。
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6.7  Read Device ダイアログダイアログダイアログダイアログ
選択的にリードを行うには、( 例えば、プログラムメモリーの一部、コン
フィギュレーションビットのみ等 )PICSTART Plus > Read Device を選択し、
Read Device ダイアログを表示します (図6.6)。 リードするオプションを選択
し、このダイアログの Read をクリックしてデバイスをリードします。
チェック印の付いたボックスに一致するメモリー領域がリードされることに
なります。グレーで示されている領域はこのデバイスでは使用できません。 
Close をクリックするとダイアログが閉じます。

Figure 6.6:  Read Device ダイアログダイアログダイアログダイアログ

選択的にリードを行うには、Read Device ダイアログ内の下記のセッティン
グを調整する必要があります。

EEPROM Data データ EEPROM を備えたデバイスでは、EPROM 
Memory ウインドウ内のデータメモリーをプログ

ラムまたはベリファイします。データ EEPROM 
と EEPROM Memory ウインドウの詳しい説明は

MPLAB IDE User’s Guide を御参照下さい。

Calibration Memory 測定メモリーを備えたデバイスでは、Calibration 
Memoryウインドウ内のデータより測定データをプ

ログラムまたはベリファイします。測定メモリー
と Calibration Memory ウインドウの詳しい説明は

MPLAB IDE User’s Guide を御参照下さい。

Code Protect Settings 選択したデバイス用にコードプロテクションの状
態と容量を示します。

Start Address プログラムメモリー内にあるリード用の開始のアドレス。

End Address プログラムメモリー内にあるリード用の終わりのアドレ
ス。

Program Memory Start Address とEnd Addressにより指定された領域用プロ
グラムメモリーをリードします。

Configuration Bits コンフィギュレーションビットをリードします。

ID Locations ID ロケーションをリードします。
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6.8  PICSTART Plus メニュー項目メニュー項目メニュー項目メニュー項目 
PICSTART Plus メニュー項目には次の機能があります。

• Enable/Disable Programmer – プログラマーをイネーブルまたはディ
セーブルします。プログラマーがいったんイネーブルになると、この
メニュー項目は Disable Programmer に変わります。

• Program/Verify – デバイスを選択的に ( 例えば、プログラムメモリーの
一部、またはコンフィギュレーションビットのみ等）プログラムでき
る、またはデバイスが正確にプログラムされたかをベリファイする
Program/Verify ダイアログ を開きます。

• Read Device – デバイスを選択的に ( 例えば、プログラムメモリーの一
部、またはデバイスのコンフィギュレーションビットのみ等）をリー
ドできる Read Device ダイアログを開きます。

• Blank Check All – デバイスが完全にブランクである (全てのビットが 
‘1’ にセットされている ) ことをチェックします。全てのコンフィギュ
レーションビットが ‘1’ ( プログラムされていない状態 ) にセットされ
ているかどうかもチェックします。

• Blank Check OTP – この機能は生産時にプログラムされているコン
フィギュレーションビットを備えた OTP デバイスを使用するための
ものです。この機能を使用する前に、表示されているコンフィギュ
レーションビットがあらかじめプログラムされているセッティングと
一致するようセットして下さい。この機能は全てのプログラムメモ
リービットが ‘1’ にセットされていること、またコンフィギュレーショ
ンビットが Configuration Bits ダイアログ内に表示されたセッティング
と一致することを確認します。

• Display Error Log – デバイスのプログラムやベリファイが終わった
時、エラーウインドウがデバイスのメモリーからのデータを表示しま
すが、それは MPLAB IDE 内の対応するメモリーと一致しないもので

EEPROM  Data データ EEPROM を備えたデバイスでは、データメモリー
内のデータを EEPROM Memory ウインドウにリードしま
す。データ EEPROM と EEPROM Memory ウインドウの
詳しい説明は、MPLAB IDE User’s Guide を御参照下さ
い。

Calibration Memory 測定メモリーを備えたデバイスでは、測定メモリー内の
データを Calibration Memory ウインドウにリードします。 
測定メモリーと Calibration Memory ウインドウの詳しい
説明は MPLAB IDE User’s Guide を御参照下さい。

Note: MPLAB-ICEがMPLAB IDEに接続していれば、コードは MPLAB-ICEのエ
ミュレーテッドプログラムメモリーにダウンロードされます。プロジェ
クトが開いている場合は、デバイスからメモリーをリードする前に閉じ
たいかどうかが質問されます。プロジェクトを開いたままにしておくと、
Absolute Listing ウインドウと Source Code ウインドウが Program Mem-
ory ウインドウにリードしたデータに一致しないことがあります。 シン
ボルが Program Memory ウインドウ内の正しいアドレスに一致しなくな
ることもあります。
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す。

• Erase Program Memory – MPLAB IDE Program Memory、Calibration 
Memory、Data Memory ( もし適切であれば ) の全てのビットを ‘1’ に
セットします。

• Erase Configuration Bits – 使用可能な全てのコンフィギュレーショ
ンビットと ID ロケーションビットを ‘1’ にセットします。コンフィ
ギュレーションビットを消去するためにこのメニュー項目を使用した
後  hexファイルまたはプロジェクトを再ロードすると、  Configuration 
Bits ダイアログ内の値は、hex ファイルまたはコード内の新しくロー
ドされたコンフィギュレーションビットデータを示そうとしてアップ
デートされます。 もし hex ファイルまたはコード内のコンフィギュ
レーションビット値を override したい時は、 hex ファイルをロードし
たり、プロジェクトを再ビルドした後もこのメニュー項目を選択する
ことができます。

• Reset Programmer – PICSTART Plus ハードウエアをリセットし、 
RS-232 コミュニケーションを再び確立します。 PICSTART Plusからの
電流がつながらない時にこのオプションを使います。このオプション
は Program Memory ウインドウ、コンフィギュレーションビットまた
は ID 内のプログラミング情報をリセットすることはありません。

6.9  PICSTART Plus オペレーティングシステムのアッオペレーティングシステムのアッオペレーティングシステムのアッオペレーティングシステムのアッ
プグレードプグレードプグレードプグレード

PICSTART Plus オペレーティングシステムでは、新しいデバイスをサポー
トするために定期的にアップグレードする必要があります。ウエブサイト 
http://www.microchip.com からアップグレード情報をダウンロードし、この
セクションの手順に従ってインストールして下さい。

必要な装置必要な装置必要な装置必要な装置

• MPLAB IDE ソフトウエアを備えた PICSTART Plus プログラマー

• ブランクまたは消去されている PIC17C44 マイクロコントローラー (25 MHz 
またはこれより速いもの )

• マイクロチップウエブサイト (http://www.microchip.com) からアップグレード
した hex ファイル ( 例えば、 psf20100.hex 等 ) 

• Phillips 社のヘッドスクリュードライバー

始める前に始める前に始める前に始める前に

PICSTART Plus ハードウエアとMPLAB IDE ソフトウエアのインストールを必ず行っ
て下さい。そして、プログラマーはシリアルポートを介して PC とコミュニケーショ
ンができるようにしておきます。 インストールの手続きについてはセクション 3.4、
シリアルポートコンフィギュレーション情報はセクション 3.7 を それぞれ御覧くだ
さい。 

Note: このファイルには MPLAB IDE の最新バージョンが載っています。
新しいオペレーティングシステムの特徴を生かすには、新しい
MPLAB IDE ソフトウエアと新しい PICSTART Plus ソフトウエア
ドライバーがおそらく必要となります。
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必要な手続き必要な手続き必要な手続き必要な手続き

1. Options > Development Mode を選択します。 MPLAB IDE の 開発モードを次の
ようにセットアップします。Editor Only、PIC17C44 デバイス

2. PICSTART Plus > Enable を選択し PICSTART Plus プログラマーをイネーブルし
ます。

3. PIC17C44がDevice Programmer ダイアログ内の選択したデバイスかどうか確
認します。もしそうでなければ、PICSTART Plus Device Programmer ダイアロ
グ内の Device リストから正しいものを選択して下さい。 

4. Configuration Bits ダイアログが表示されていない場合は、PICSTART Plus
Device Programmer ダイアログ内の Configuration Bits をクリックして下さ
い。  Configuration Bit ダイアログ内のコンフィギュレーションビットは下記の
ようにセットします。

- Oscillator: XT
- Processor Mode: Microcontroller 
- Watchdog Timer: TMR

5. File > Import > Import to Memory を選択し、アップグレードした hex ファイルを
MPLAB IDE の プログラムメモリーにインポートします。 アップグレードした
hex ファイルを選択し、OK をクリックします。

6. PIC17C44 マイクロコントローラーを PICSTART Plus ソケットにはめ込み、
PICSTART Plus Device Programmer ダイアログ内の Blank をクリックして、ブ
ランクであることを（セクション 5.3.5 を御覧下さい）チェックします。もし
デバイスがブランクでない場合は、プログラムする前に必ず消去を行って下さ
い。 

7. PICSTART Plus Device Programmer ダイアログ内の Program をクリックし、
hex ファイルをデバイスにプログラムします。

8. プログラミングソケットから PIC17C44 を取り外し、アップグレードバージョ
ン（例えば VER 2.01.00 等 ) のラベルを付けておきます。

9. MPLAB IDEを終了させ、PICSTART Plusをコンピューターシリアルポートと電
源から取り外します。

10. PICSTART Plus の裏側にある４つの Phillips 社ヘッドスクリューを注意しなが
らはずし、後ろのカバーを取り外して下さい。

11. PICSTART Plus PCB の装備を取り外します。

12. PIC17C44をPICSTART Plus PCBから注意しながら取り外します。 後でアップ
グレード用に必要となる場合があるので、このバージョンをセーブしておきま
す。

13. プログラムしたばかりの PIC17C44 を、Pin 1 が正しい方向に向いているかどう
かを確認しながら (Pin 1 はシリアルポートコネクターのそばに位置するはずで
す）ソケットに注意深くはめ込んで下さい。 

14. PICSTART Plus PCB を装備の中に戻します。

15. Phillips 社のヘッドスクリューを後ろのカバーにある穴に静かにはめ込み、ゆっ
くりそれぞれのスクリューを締めていきます。 スクリューをまわす時に力を入
れすぎると、プラスティックの装備が壊れることがあります。

16. PICSTART Plus プログラマーをコンピューターシリアルポートと電源に再び
つなぎます。

17. MPLAB IDE ソフトウエアを開始させ、PICSTART Plus プログラマーをイネーブ
ルにします。

18. プログラマーがイネーブルになっているので、ダイアログボックス
は PICSTART Plus オペレーティングシステムバージョンを表示するはずです。
Help > About MPLAB を選択したり、Registered Applications のリストにある
PICSTART Plus をロケートすることによっても、バージョンをチェックするこ
とができます。

PICSTART Plus オペレーティングシステムのアップグレードはこれで完了です。 
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Appendix A.  25- ピンシリアルポートへの接続ピンシリアルポートへの接続ピンシリアルポートへの接続ピンシリアルポートへの接続 

A.1 はじめにはじめにはじめにはじめに
この appendix（付録）には、 PICSTART Plus プログラマーと 25- ピンシリ
アルポートの接続のしかたが書いてあります。

A.2 ポイントポイントポイントポイント
この appendix で扱う項目は次のとうりです。

• 接続方法

A.3 接続方法接続方法接続方法接続方法
下記の表が PICSTART Plus プログラマー (9- ピン垂直型 ) と 25- ピンシリア
ルポートの接続用データを示しています。表の各行に示されているそれぞれ
対応する端末どうしをつなぎます。

Table A.1:  PC ホストからホストからホストからホストから PICSTART Plus シグナルへシグナルへシグナルへシグナルへ 

25- ピンピンピンピン (PC ホスホスホスホス
トトトト )  9- ピンピンピンピン (PICSTART Plus)

2 TX 2 RX

3 RX 3 TX

20 DTR 4 DTR

7 Common 5 Common

6 DSR 6 +5 ボルト (pulled 
up)

4 RTS 7 CTS

5 CTS 8 RTS
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NOTES:
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PICSTART Plus VPP の調整の調整の調整の調整

Appendix B.  PICSTART Plus VPP の調整の調整の調整の調整

B.1 はじめにはじめにはじめにはじめに
この appendix（付録）では、 改訂されたプログラミング仕様に従うようにす
るには、古くなった PICSTART Plus ハードウエア ユニットの VPP プログラ
ミング電圧をどのように変えればよいか説明しています。

B.2 ポイントポイントポイントポイント
この付録で扱う項目は次のとうりです。

• 検討

• 手順

• 確認

B.3 検討検討検討検討
現時点での Microchip 社のプログラミング仕様を保存するためには、どの 
PICSTART Plus にも、すなわち Revision 7 またはそれ以前のものにも VPP 電
圧に調整が少し必要となります。この調整では VPP 電圧が名目上の 13.75 
ボルトから 名目上の 13.00 volts になります。この調整は、PICSTART Plus
の導入後、プログラミング仕様のアップデートを行ったことにより必要とな
るものです。

B.4 手順手順手順手順
PICSTART Plus のバージョンアップを確認するには、裏側にあるラベルを見
て下さい。シリアル番号の最後が Rx になっているはずです。この x は 
PICSTART Plus のその時のバージョン ( 例えば -R7 や -R13 等 ) です。もしこ
の番号が R7 またはそれより少ない数の場合は、下記の２つのいずれかの方
法で VPP 電圧を 13.00V に調整して下さい。

方法方法方法方法 1: 
レジスター R4 を出し、562 kOhm 1% レジスターを R4 を横切るように結合
させます。これにより R4 の値が下がり、VPP 電圧が 13.00V に下がります。

Method 2: 
レジスター R4 を出し、R4 を取り除いて 22.6 kOhm 1% レジスターと取り
替えます。これにより VPP 電圧が 13.00V に下がります。
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B.5 確認確認確認確認
以上の手順を終えたら、9V を PICSTART Plus で使用して、 Capacitor C5 に
より電圧を測ってみます。 13.00 (12.75 ～ 13.25) ボルトになっているはずで
す。 電圧が正しい値ならば、変更は完了です。 正しくない場合は、手順が正
確に行われたかどうか、また作業をした付近での接続不良がないかどうか確
認して下さい。
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問題解決方法問題解決方法問題解決方法問題解決方法

Appendix C.  問題解決方法問題解決方法問題解決方法問題解決方法 

C.1 はじめにはじめにはじめにはじめに
この appendix（付録）には、PICSTART Plus を使う時に発生するよくある
問題点や、それらを解決するためのステップが書いてあります。

C.2 ポイントポイントポイントポイント
この付録で取り扱う項目は次のとうりです。

• 一般的な問題

C.3 一般的な問題一般的な問題一般的な問題一般的な問題
MPLAB IDE が次のメッセージを示すが次のメッセージを示すが次のメッセージを示すが次のメッセージを示す: “Failed to Establish Communication.(コミュコミュコミュコミュ
ニケーションの確立に失敗しました）ニケーションの確立に失敗しました）ニケーションの確立に失敗しました）ニケーションの確立に失敗しました）”
MPLAB IDE は、プログラマーをイネーブルすることにより PICSTART Plus デバイス
プログラマーとのコミュニケーションを試みます。コミュニケーションが確立できな
いと、プログラミングは行えません。コミュニケーションを確立しようとして失敗す
ると、ダイアログボックスが出てきます。もしそうなった場合、問題を解決してから
再び試みるかキャンセルして下さい。

解決方法 :
• RS-232 cable ケーブルがつなっがていること、電源 が入っていること、PIC-

START Plus 上の Power LED がオンになっていることを確認して下さい。

• PICSTART Plusを他のシリアルポートに接続してみて下さい。もしPC に 25ピ
ンシリアルポートがあれば 25-to-9 シリアルポートアダプターが必要となりま
す。 

• PICSTART Plus の使用のみのためにCOM ポートが正しくセットアップされて
いるかどうかを確認します。リソースが正しく動作しているかどうか、他の
デバイスと対立していないかどうかをチェックして下さい。これは一般に正
しくコンフィギュアされていないモデムまたは他のシリアルデバイスを使用
すると発生します。ウインドウのマニュアル、または他の解説書をお読み下
さい。対立を起こしているデバイスの移動、再コンフィギュア、またはディ
セーブルを行なうことは可能ですが、それらの扱い方に詳しい場合のみ行っ
て下さい。Windows 3.1 または Windows 95/98 については後述のステップを
ご覧ください。

• システムエラーのいくつかは、ドライバーとハードウエアの非互換性により
生じています。Windows 95/98 については後述のステップを御覧下さい。
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• COM ポートがあるのに MPLAB IDEでそれを選択できない場合 (オプションが
グレーで示されている )、 mplab.iniファイルをエディットして手動でポート
を選ぶことができます。これは COM ポートリストにとぎれがある時 ( 例え
ば、COM1、COM2、COM4 はあるが、COM3 がない等 ) に生じる典型的な例
です。このような場合、 mplab.ini ( このファイルを出すには FIND を使いま
す ) を開き、[programmers] と呼ばれるセクションをエディットして直すこと
ができます。これによりセッティングの CommPort=1 が、選択したいポート
にセットされます。これはまだほんの小さな問題解決に過ぎません。Win-
dows オペレーティングシステムが16ビットドライバーを通じてポートの有効
性を不正確に伝えているような大きな問題もあるのです。

• 使用する Windows のバージョン用に使える Microsoft Windows コミュニケー
ションドライバーを必ず使用して下さい。Windows 3.10 を使用する場合、 
\WINDOWS\SYSTEM ディレクトリー内のファイル COMM.DRV を探して下さ
い。そのファイルは必ず 3:10a のタイムを持っているはずです。このタイムが
バージョンを表しています。Windows をワークグループで使用する場合、上
と同じファイルを探しますが、ファイルのタイム表示は 3:11a となるはずで
す。もしこれらのファイルが異なる場合は、Windows オペレーティングシス
テムを再インストールするか、そのファイルを他のソースからインストール
する必要があります。この問題は Windows 95/98 で起こることはまずありま
せん。

• サードパーティーコミュニケーションを使用していないことを確認して下さ
い。system.iniファイルを開き、 [OPTIONS] の箇所で次の一行を探します。

COMM.DRV=COMM.DRV

もしこの行に違うものが書いてある場合、別のコミュニケーションドライバー
を使用していることがわかります。

Windows 3.1: 
シリアルマウスは外部のモデムと同様に COM ポートを使用します。内部モデム
はそれ自身の COM ポートを持っているので、 PC 上に第二の COM ポートがある
場合は、マウスとモデムに対立することのないようにセットする必要があります。

Windows 95/98, Windows NT, Windows 2000: 
Windows 95/98、 Windows NT、Windows 2000 は COM ポートをセットアップす
るのに特に注意が必要です。ドライバー、すなわちハードウエアの非互換性に問
題の疑いがある場合は、Flow Control to Hardware を変えてみるか（一方または
同時に）シリアルポート用の FIFO を消して下さい。これは Control Panel で行わ
れます。

Windows 95/98 では System アイコンをクリックします。そして Device Manager
タブ、Ports をクリックして下さい。もし必要ならば、Port 選択をそのとなりに
ある “+” サインをクリックすることにより広げます。   PICSTART Plus が接続され
ている I/O ポートをダブルクリックして下さい。ここで Hardware に flow control
がセットできるのです。FIFO を消すには、 Advanced ボタンをクリックし、Use
FIFO ボックスの選択を解除し、OK をクリックします。

Windows NT では Ports アイコンをクリックします。COM ポートを選択し、Set-
tingsをクリックしてAdvanced ボタンをクリックして下さい。そしてFIFI ボック
スの選択を解除し、OK をクリックして下さい。

Windows 2000 では System アイコンをクリックします。Hardware タブをクリッ

クし、Device Manager ボタンをクリックして下さい。もし必要ならば、Port 選
択をそのとなりにある “+” サインをクリックすることにより広げます。   PIC-
START Plus が接続されている I/O ポートをダブルクリックして下さい。ここで
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問題解決方法問題解決方法問題解決方法問題解決方法

Hardware に flow control がセットできるのです。FIFO を消すには、Port Settings
タブをクリックし、Advanced ボタンをクリックします。Use FIFO ボックスの

選択を解除し、OK をクリックして下さい。



PICSTART® Plus User’s Guide

DS51028C_J-page 78 　　　　　　　　　　　　　 2000 Microchip Technology Inc.　
　　　　　　　　　　 この日本語ドキュメントは参考資料です。　最新版英語ドキュメントをご参照下さい。                                                                                                                                  
　　　　　　　　　　　　　　　　　　　(http://www.microchip.com から入手できます )

PICSTART Plus メニューが見つからないメニューが見つからないメニューが見つからないメニューが見つからない

他のプログラマー ( 例えば PRO MATE II 等 ) を使っている場合は PICSTART Plus メ
ニューは使用できないことがあります。

解決方法 :
Options > Programmer Options > Select Programmer を選択して Select Programmer 
ダイアログを開き、 リストから PICSTART Plus を選びます。プログラマーを選択し
た後に、MPLAB IDE は注意を促して自動的に閉じます。プログラマーオプションが
使用可能になる前に必ず MPLAB IDE を再スタートさせて下さい。MPLAB IDE を再
スタートさせると、PICSTART Plus メニューがメニューバー上に現れます。

オペレーションシステムのアップグレードが必要であるオペレーションシステムのアップグレードが必要であるオペレーションシステムのアップグレードが必要であるオペレーションシステムのアップグレードが必要である

MPLAB IDE で開発モードをセットアップしている時に選択したデバイスが、
PICSTART Plus オペレーティングシステムによりサポートされていない場合は、プ
ログラマーをイネーブルしようとするとメッセージボックスが現れます。

解決方法 :
セクション 6.9 に示されているように、PICSTART Plus オペレーティングシステム
のバージョンをアップグレードして下さい。MPLAB IDE ソフトウエアと PICSTART 
Plus オペレーティングシステム (セクション 6.9)の最新バージョンを必ず入手するよ
うにして下さい。

MPLAB IDEを備えたを備えたを備えたを備えたPICSTART Plus をイネーブルしようとすると次のメッセージがをイネーブルしようとすると次のメッセージがをイネーブルしようとすると次のメッセージがをイネーブルしようとすると次のメッセージが
現れる現れる現れる現れる : “Incompatible Software and Operating System Versions .（ソフトウエア（ソフトウエア（ソフトウエア（ソフトウエア
とオペレーティングシステムバージョンが非互換性です）とオペレーティングシステムバージョンが非互換性です）とオペレーティングシステムバージョンが非互換性です）とオペレーティングシステムバージョンが非互換性です）”
ソフトウエアのバージョンとオペレーティングシステムが混合しています。
PICSTART Plus と MPLAB IDE は、バージョン要求が一致していることを確認するた
めの互換性チェック機能を備えています。 
解決方法 :
MPLAB IDE ソフトウエアと PICSTART Plus オペレーティングシステム ( セクション
6.9) の最新バージョンを必ず入手するようにして下さい。

MPLAB IDE が次のメッセージを表示するが次のメッセージを表示するが次のメッセージを表示するが次のメッセージを表示する : “Hex file not found.（（（（Hex ファイルが見ファイルが見ファイルが見ファイルが見
つかりません）つかりません）つかりません）つかりません）”
プロジェクトが hex ファイルを作成していません。

解決方法 :
MPLAB IDE 上の Make Project パネルをチェックし、アセンブルやコンパイルを行っ
た時に hex ファイルが作成されていることを確認して下さい。コード上のエラーは
hex ファイル作成を妨げます。

MPLAB IDE が次のメッセージを表示するが次のメッセージを表示するが次のメッセージを表示するが次のメッセージを表示する : “Program memory contains code 
protected data. Proceed with programming?（プログラムメモリーにコードプロテ（プログラムメモリーにコードプロテ（プログラムメモリーにコードプロテ（プログラムメモリーにコードプロテ
クタデータがあります。プログラミングを続行しますか？）クタデータがあります。プログラミングを続行しますか？）クタデータがあります。プログラミングを続行しますか？）クタデータがあります。プログラミングを続行しますか？）”

プログラムメモリーにコードプロテクトされたデバイスからリードされたデータがあ
ります。このデータのほとんどまたはすべては使用できません。

解決方法 :
ファイルまたはプロテクトされていないデバイスからもとの hex コードを入手して
下さい。

デバイスをリードしている時デバイスをリードしている時デバイスをリードしている時デバイスをリードしている時 MPLAB IDE が次の注意メッセージを出すが次の注意メッセージを出すが次の注意メッセージを出すが次の注意メッセージを出す : “Device is 
code protected. Program memory may be invalid.（デバイスはコードプロテクト（デバイスはコードプロテクト（デバイスはコードプロテクト（デバイスはコードプロテクト
されています。プログラムメモリーが無効になるかもしれません。）されています。プログラムメモリーが無効になるかもしれません。）されています。プログラムメモリーが無効になるかもしれません。）されています。プログラムメモリーが無効になるかもしれません。）”

コードプロテクトされたデバイスをリードしようとするとこの注意が出て来ます。
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問題解決方法問題解決方法問題解決方法問題解決方法

解決方法 : 
ファイルまたはプロテクトされていないデバイスから元の hex コードを入手して下
さい。

使用可能なメニュー機能が作動しない使用可能なメニュー機能が作動しない使用可能なメニュー機能が作動しない使用可能なメニュー機能が作動しない

他の多くのアプリケーションと同様に、MPLAB IDE と PICSTART Plus は Borland’s 
bwcc.dllを使用しています。従ってこの DLL の他のバージョンがツールのオペレー
ションを妨げることがあります。 
解決方法 :
DLL の他のどのコピーが使用している機器に入っているのかを確かめて、それらがす
べて最新バージョン（BWCC.DLL は backward コンパチブルです）であることを確
認して下さい。そして機器を reboot し、 MPLAB IDE を実行します。

ブランクのミッドレンジデバイスのブランクチェックが失敗したブランクのミッドレンジデバイスのブランクチェックが失敗したブランクのミッドレンジデバイスのブランクチェックが失敗したブランクのミッドレンジデバイスのブランクチェックが失敗した

v1.01.16 の前の PICSTART Plus オペレーティングシステムバージョンは、パワー
アップ後にデバイスに最初にアクセスをする時に最初の ID ロケーションを誤ってプ
ログラムすることがあります。 バージョン 1.01.00 では時々、v1.01.06 では一貫して
これが起こります。

解決方法 :
セクション 6.9 での手順のあらましに従い、最新のオペレーティングシステムバー
ジョンまでアップグレードして下さい。

PIC16C73, PIC16C74: ブランクであるはずのパーツがノンブランクと表示されるブランクであるはずのパーツがノンブランクと表示されるブランクであるはずのパーツがノンブランクと表示されるブランクであるはずのパーツがノンブランクと表示される

いくつかの PIC16C7X (PIC16C73, PIC16C74) デバイスをプログラムする時には、ブ
ランクであるはずのパーツがブランクではないと表示され、正しくプログラムが行わ
れないことがあります。この問題は、  VPP の立ち上がり時間が早すぎてパーツがプロ
グラミングモードに正しくセットされないことにより生じます。これはパーツの特定
の日にちコードと PIC16C7XA 以外のパーツでのみ生じます。

解決方法 :
パーツをはめ込む前に、0.01 µF キャパシターを VPP ( ピン 1) とソケットのグランド
(ピン8)の間に差し込みます。 これによりVPPの立ち上がり時間が遅くなり、デバイス
はプログラミングモードに入ることができます。 
ブランクのブランクのブランクのブランクの PIC16C55A またはまたはまたはまたは PIC16C57C をリードしている時、をリードしている時、をリードしている時、をリードしている時、0xBFF のプログラのプログラのプログラのプログラ
ムメモリー値が報告されないムメモリー値が報告されないムメモリー値が報告されないムメモリー値が報告されない

これらのデバイス用のオシレータ回路は前のデバイスと異なっており、リード動作の
期間に構造的な摩擦を生じる可能性があります。

解決方法 :
OSC2 ( ピン 26) クリップの付いたスタンドオフソケットを使用して下さい。 
PIC16F87X デバイス使用中にプログラムとリードに問題が生じるデバイス使用中にプログラムとリードに問題が生じるデバイス使用中にプログラムとリードに問題が生じるデバイス使用中にプログラムとリードに問題が生じる

PIC16F87X デバイスは低電圧プログラミングでイネーブルされた状態で輸送されま
す。 
PICSTART Plus は高電圧メソッドを使用しています。低電圧プログラミングがイ
ネーブルになっている場合、デバイスによっては正しくプログラミングモードが終了
せず、リード及びプログラミングオペレーション結果が invalid になることがありま
す。

解決方法 :
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RB3 ピンと、プログラミングソケット上のグランドピンの一つの間に、 10 kOhm レジ
スタを設置して下さい。使用しているデバイスのピン配置についてはデバイスデータ
シートを御参照下さい。

電流が遮断される電流が遮断される電流が遮断される電流が遮断される

PICSTART Plus v1.20 またはそれ以上の電圧のものは機能切り替えの途中に電流の遮
断が起きることがわかっています。初期のバージョンのものには起こりません。

解決方法 :
PICSTART Plus DLL の初期のバージョンを使用している時に電流が遮断された場合
は、プログラマーに電流を供給し、Programmer Status ウインドウより使用したいデ
バイスを再び選択して下さい。

LED フリッカーまたはパワーフリッカーまたはパワーフリッカーまたはパワーフリッカーまたはパワー LED がオンにならないがオンにならないがオンにならないがオンにならない

パーツの選択が正しくないか、またはデバイスの差し込み方が正しくないことによ
り、thermal ヒューズが飛んでいます。

解決方法 :
PICSTART Plus上のデバイスと cycle powerを取り除き、内部の thermalヒューズをリ
セットして下さい。

パワーパワーパワーパワー LED が点かないが点かないが点かないが点かない

電力供給に互換性が無いか、または電力供給の極性が逆になっています。

解決方法 :
使用されている電力供給が PICSTART Plus に備わっているものか、またはセクショ
ン 3.4.2 に特徴が示されているような互換性のあるものか確かめます。それでもユ
ニットが点かない場合は、マイクロチップ社のサポート担当まで御連絡下さい。

12またはまたはまたはまたは14ビットデバイス用にビットデバイス用にビットデバイス用にビットデバイス用に 14またはまたはまたはまたは16ビットビットビットビットhexファイルをインポートしていファイルをインポートしていファイルをインポートしていファイルをインポートしてい
る時、る時、る時、る時、PICSTART Plus はエラーなしにデバイスをプログラムするが、手動の確認ではエラーなしにデバイスをプログラムするが、手動の確認ではエラーなしにデバイスをプログラムするが、手動の確認ではエラーなしにデバイスをプログラムするが、手動の確認で
は失敗するは失敗するは失敗するは失敗する 
解決方法 :
MPLAB IDE はコアサイズに合わせるために、自動的に hex ファイルを短くします。例
えば AAAAhの値を持つ hex ファイルを作り、 そのファイルを 14 ビットデバイスに
ロードすると、表示される値は 2AAAhになります。 PICSTART Plus はエラーなしに
デバイスをプログラムしますが、メモリーに保存された値は AAAAhなので、手動の
確認ができなくなるのです。

hex ファイルまたは Modify ダイアログをロードすることによりプログラムメモリー
に入れられた値は、コアサイズまで短くする必要があります。
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